<html>
  <head>
    <meta content="text/html; charset=windows-1252"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    Hello Saurabh,<br>
    <br>
    thank you for reporting this.<br>
    <br>
    I analyzed your questions and this are the results:<br>
    <br>
    a) wfs:wfs-1.1.0-Basic-GetCapabilities-tc7<br>
    The test expects XML but HTML is returned when requesting <a
      moz-do-not-send="true"
href="http://localhost:19090/maps?version=1.1.0#request=GetCapabilities,service=WFS"
      target="_blank"><a class="moz-txt-link-freetext" href="http://localhost:19090/maps?version=1.1.0#request=GetCapabilities,service=WFS">http://localhost:19090/maps?version=1.1.0#request=GetCapabilities,service=WFS</a></a><br>
    <br>
    <div>b) wfs:wfs-1.1.0-Basic-GetCapabilities-tc13<br>
      Please see <a class="moz-txt-link-freetext" href="https://github.com/opengeospatial/ets-wfs11/issues/52">https://github.com/opengeospatial/ets-wfs11/issues/52</a><br>
      <br>
      c) wfs:wfs-1.1.0-Basic-DescribeFeatureType-POST-tc1<br>
      ':BasicPolygonsType' is not a valid QName.<br>
      <br>
      <div>a) getmap:bbox-pixel-interpretation<br>
        Please see <a class="moz-txt-link-freetext" href="https://github.com/opengeospatial/ets-wms13/issues/29">https://github.com/opengeospatial/ets-wms13/issues/29</a><br>
      </div>
      <br>
      <div>b) getfeatureinfo:query_layers-not-queryable</div>
      Your sever does not return an Exception with
      code=LayerNotQueryable when requesting <a moz-do-not-send="true"
href="http://localhost:19090/maps?&LaYeRs=MS&ReQuEsT=GetFeatureInfo&BbOx=-90,-180,90,180&WiDtH=100&CrS=EPSG%3A4326&QuErY_LaYeRs=MS&VeRsIoN=1.3.0&StYlEs=&I=50&J=50&HeIgHt=100&InFo_fOrMaT=text%2Fhtml&FoRmAt=image%2Fpng"
        target="_blank">http://localhost:19090/maps?&LaYeRs=MS&ReQuEsT=GetFeatureInfo&BbOx=-90,-180,90,180&WiDtH=100&CrS=EPSG%3A4326&QuErY_LaYeRs=MS&VeRsIoN=1.3.0&StYlEs=&I=50&J=50&HeIgHt=100&InFo_fOrMaT=text%2Fhtml&FoRmAt=image%2Fpng</a><br>
      <br>
      cs2:get-kvp-core-req12<br>
      Documented in
      <a class="moz-txt-link-freetext" href="https://github.com/opengeospatial/ets-wcs20/issues/14">https://github.com/opengeospatial/ets-wcs20/issues/14</a><br>
      <br>
      For several questions I opened issues on github. By this we can
      keep all thoughts about an issue bundled and all results are
      archived well structured. I hope that is fine for you.<br>
      <br>
      Kind regards,<br>
      Dirk<br>
    </div>
    <br>
    <br>
    <br>
    <div class="moz-cite-prefix">Am 13.04.2016 um 08:43 schrieb saurabh
      kumar via CITE-Forum:<br>
    </div>
    <blockquote
cite="mid:CADvGoozjnS5NCEAgGaVkC=bDn40Fc+89muCWCS0bmjRhxM=0sg@mail.gmail.com"
      type="cite">
      <div dir="ltr">
        <div class="gmail_quote">
          <div dir="ltr">Hi,
            <div><br>
            </div>
            <div>
              <div>I'm testing WFS through ogc test and some of the test
                cases are getting failed and i'm not able to find any
                solution.</div>
              <div><br>
              </div>
              <div>Test cases failed</div>
              <div><br>
              </div>
              <div>a) wfs:wfs-1.1.0-Basic-GetCapabilities-tc7</div>
              <div><br>
              </div>
              <div> Resuest : <a moz-do-not-send="true"
href="http://localhost:19090/maps?version=1.1.0#request=GetCapabilities,service=WFS"
                  target="_blank">http://localhost:19090/maps?version=1.1.0#request=GetCapabilities,service=WFS</a></div>
              <div> Assertion: A valid http URL value shall conform to
                the syntax specified in RFC 2616. http_URL = 'http:'
                '//' host [</div>
              <div>  ':' port ] [ abs_path [ '?' query ]]</div>
              <div><br>
              </div>
              <div> ERROR : Messages from parser
                p:XMLValidatingParser.GMLSF1:</div>
              <div>         Validation error:</div>
              <div>         cvc-elt.1.a: Cannot find the declaration of
                element 'HTML'.</div>
              <div>b) wfs:wfs-1.1.0-Basic-GetCapabilities-tc13</div>
              <div><br>
              </div>
              <div> Request : <a moz-do-not-send="true"
href="http://localhost:19090/maps?&version=1.1.0&request=GetCapabilities"
                  target="_blank">http://localhost:19090/maps?&version=1.1.0&request=GetCapabilities</a></div>
              <div> Error in call to extension function {public
                org.w3c.dom.NodeList
                com.occamlab.te.TECore.request(org.w3c.dom.Document,java.lang.String)
                throws java.lang.Throwable}: Exception in extension
                function java.lang.reflect.InvocationTargetException</div>
              <div> Result: Failed</div>
              <div>c) wfs:wfs-1.1.0-Basic-DescribeFeatureType-POST-tc1</div>
              <div><br>
              </div>
              <div>Assertion: The following attributes are required for
                all XML request entities: @version (default '1.1.0');</div>
              <div>  @service (default 'WFS').</div>
              <div> Messages from parser
                p:XMLValidatingParser.XMLSchema:</div>
              <div>Validation error:</div>
              <div>     cvc-datatype-valid.1.2.1: ':BasicPolygonsType'
                is not a valid value for 'QName'.</div>
              <div>Validation error:</div>
              <div>      cvc-attribute.3: The value ':BasicPolygonsType'
                of attribute 'type' on element 'element' is not valid
                with respect to its type, 'QName'.</div>
              <div><br>
              </div>
              <div>Where BasicPolygons is a vector layer name.</div>
              <div><br>
              </div>
              <div><br>
              </div>
              <div><br>
              </div>
              <div><br>
              </div>
              <div>There are few test cases which are getting failed and
                i'm not able to find any solution for the same.</div>
              <div><br>
              </div>
              <div>1) WMS(1.3.0) - Test cases failed</div>
              <div><br>
              </div>
              <div>a) getmap:bbox-pixel-interpretation</div>
              <div><br>
              </div>
              <div>  Request : <a moz-do-not-send="true"
href="http://localhost:19090/maps?&StYlEs=&HeIgHt=7&CrS=CRS:84&BbOx=0.0016,-0.0012,0.0026,-0.0005&WiDtH=10&FoRmAt=image%2Fpng&ReQuEsT=GetMap&VeRsIoN=1.3.0&LaYeRs=cite:Lakes"
                  target="_blank">http://localhost:19090/maps?&StYlEs=&HeIgHt=7&CrS=CRS:84&BbOx=0.0016,-0.0012,0.0026,-0.0005&WiDtH=10&FoRmAt=image%2Fpng&ReQuEsT=GetMap&VeRsIoN=1.3.0&LaYeRs=cite:Lakes</a></div>
              <div><br>
              </div>
              <div>  Assertion: The server interprets the bounding box
                as going around the &quot;outside&quot; of the
                pixels of the image rather than through the centers of
                the border pixels.</div>
              <div>b) getfeatureinfo:query_layers-not-queryable</div>
              <div><br>
              </div>
              <div> Request : <a moz-do-not-send="true"
href="http://localhost:19090/maps?&LaYeRs=MS&ReQuEsT=GetFeatureInfo&BbOx=-90,-180,90,180&WiDtH=100&CrS=EPSG%3A4326&QuErY_LaYeRs=MS&VeRsIoN=1.3.0&StYlEs=&I=50&J=50&HeIgHt=100&InFo_fOrMaT=text%2Fhtml&FoRmAt=image%2Fpng"
                  target="_blank">http://localhost:19090/maps?&LaYeRs=MS&ReQuEsT=GetFeatureInfo&BbOx=-90,-180,90,180&WiDtH=100&CrS=EPSG%3A4326&QuErY_LaYeRs=MS&VeRsIoN=1.3.0&StYlEs=&I=50&J=50&HeIgHt=100&InFo_fOrMaT=text%2Fhtml&FoRmAt=image%2Fpng</a></div>
              <div> Assertion: When GetFeatureInfo is requested on a
                Layer that is not queryable, then the server issues a
                Service Exception (code=LayerNotQueryable).</div>
              <div><br>
              </div>
              <div><br>
              </div>
              <div> I'm testing wcs(2.0.1) through ogc compliance test
                and some of the test cases are getting failed with an
                error : The server does not support the gml coverage.</div>
              <div><br>
              </div>
              <div>Test case id : cs2:get-kvp-core-req12</div>
              <div><br>
              </div>
              <div>Assertion: req12: For all WCS request types, test the
                request version parameter has     a fixed value of
                '2.0.1' by GetKVP.</div>
              <div>Message d9183e2208_1: [MESSAGE] The server does not
                support the gml coverage.</div>
              <div><br>
              </div>
              <div>Result: Failed</div>
              <div><br>
              </div>
              <div>Any suggestions to solve this issue.</div>
            </div>
            <div><br>
            </div>
            <div>Thanks</div>
            <span class="HOEnZb"><font color="#888888">
                <div>Saurabh kumar</div>
              </font></span></div>
        </div>
        <br>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
CITE-Forum mailing list
<a class="moz-txt-link-abbreviated" href="mailto:CITE-Forum@lists.opengeospatial.org">CITE-Forum@lists.opengeospatial.org</a>
<a class="moz-txt-link-freetext" href="https://lists.opengeospatial.org/mailman/listinfo/cite-forum">https://lists.opengeospatial.org/mailman/listinfo/cite-forum</a>
</pre>
    </blockquote>
    <br>
  </body>
</html>