<div dir="ltr">Hi, <br><br>Thank you for the quick reply !<div>Everything is fine know.</div><div><span style="color:rgb(38,50,56);font-family:'Helvetica Neue',arial,sans-serif;font-size:13px;line-height:16px">All tests pass for WMS 1.3 and 1.1.1.</span></div><div><span style="color:rgb(38,50,56);font-family:'Helvetica Neue',arial,sans-serif;font-size:13px;line-height:16px"><br></span></div><div><font color="#263238" face="Helvetica Neue, arial, sans-serif"><span style="line-height:16px">Cordially</span></font><span style="color:rgb(38,50,56);font-family:'Helvetica Neue',arial,sans-serif;font-size:13px;line-height:16px">,</span></div><div><span style="color:rgb(38,50,56);font-family:'Helvetica Neue',arial,sans-serif;font-size:13px;line-height:16px">Etienne</span></div></div><div class="gmail_extra"><br><div class="gmail_quote">2016-04-07 19:10 GMT-04:00 Richard Martell <span dir="ltr"><<a href="mailto:rmartell@galdosinc.com" target="_blank">rmartell@galdosinc.com</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">





<div lang="EN-US" link="blue" vlink="purple">
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">Étienne,<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">Three tests fail.<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">1. wmsops-getcapabilities-response-2
<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">There are several validation errors: “The content of element type "Layer" must match "(Name?,Title,Abstract?,…”
<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">Note that Title must follow Name.<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">2. wmsops-getmap-each-layer<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">This failed due to an unexpected content type: “application/vnd.ogc.se_xml;charset=utf-8”.
<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">Reports “The coordinate system is not defined”, and the SRS param is empty in the request URI.<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">However, the requested layer is “wms1.1.1” which is actually the root layer. You should remove the Name from the root layer, since it’s generally not a named
 layer that can be requested.<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">3.  wmsops-getmap-each-srs<u></u><u></u></span></p><span class="">
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">A sequence of more than one item is not allowed as the first argument of string() (<Name/>, <Name/>)<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
</span><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">Two named layers are identified here because the root layer has a Name. Remove that and this should work.<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">--<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d">Richard<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<div>
<div style="border:none;border-top:solid #e1e1e1 1.0pt;padding:3.0pt 0in 0in 0in">
<p class="MsoNormal"><b><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">From:</span></b><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"> CITE-Forum [mailto:<a href="mailto:cite-forum-bounces%2Brmartell" target="_blank">cite-forum-bounces+rmartell</a>=<a href="mailto:galdosinc.com@lists.opengeospatial.org" target="_blank">galdosinc.com@lists.opengeospatial.org</a>]
<b>On Behalf Of </b>Richard Martell via CITE-Forum<br>
<b>Sent:</b> Thursday, 07 April, 2016 10:58<br>
<b>To:</b> Étienne Moiroux <<a href="mailto:emoiroux@k2geospatial.com" target="_blank">emoiroux@k2geospatial.com</a>>; Luis Bermudez <<a href="mailto:lbermudez@opengeospatial.org" target="_blank">lbermudez@opengeospatial.org</a>><br>
<b>Cc:</b> <a href="mailto:cite-forum@lists.opengeospatial.org" target="_blank">cite-forum@lists.opengeospatial.org</a></span></p><div><div class="h5"><br>
<b>Subject:</b> Re: [CITE-Forum] WMS 1.1.1 exception<u></u><u></u></div></div><p></p>
</div>
</div><div><div class="h5">
<p class="MsoNormal"><u></u> <u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">Hi Étienne,<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">I observed more failing tests--the service may be misconfigured. For example, this request is submitted in test ‘wmsops-getmap-params-bbox-1’; the response is expected to be
 an image: “Does the image above depict a large diamond that fills the frame?”.<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"><</span><a href="http://vpn.k2geospatial.com:9999/wms1_1/wms?VERSION=1.1.1&REQUEST=GetMap&LAYERS=cite:BasicPolygons&STYLES=&SRS=EPSG:4326&BBOX=-1,-1,1,+1&WIDTH=400&HEIGHT=400&FORMAT=image/png" target="_blank"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">http://vpn.k2geospatial.com:9999/wms1_1/wms?VERSION=1.1.1&REQUEST=GetMap&LAYERS=cite:BasicPolygons&STYLES=&SRS=EPSG:4326&BBOX=-1,-1,1,+1&WIDTH=400&HEIGHT=400&FORMAT=image/png</span></a><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">><u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">The response includes an exception report:<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"><ServiceExceptionReport><u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">    <ServiceException><u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">class "com.kheops.jmap.server.wms.WmsGetMapRequestUtil"'s signer information does not match signer information of other classes in the same package<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"></ServiceException><u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"></ServiceExceptionReport><u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">--<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">Richard<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><b><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">From:</span></b><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"> Étienne Moiroux [</span><a href="mailto:emoiroux@k2geospatial.com" target="_blank"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">mailto:emoiroux@k2geospatial.com</span></a><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">]
<br>
<b>Sent:</b> Tuesday, 05 April, 2016 12:44<br>
<b>To:</b> Luis Bermudez <</span><a href="mailto:lbermudez@opengeospatial.org" target="_blank"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">lbermudez@opengeospatial.org</span></a><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">><br>
<b>Cc:</b> Richard Martell <</span><a href="mailto:rmartell@galdosinc.com" target="_blank"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">rmartell@galdosinc.com</span></a><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">>;
</span><a href="mailto:cite-forum@lists.opengeospatial.org" target="_blank"><span style="font-size:11.0pt;font-family:"Calibri",sans-serif">cite-forum@lists.opengeospatial.org</span></a><span style="font-size:11.0pt;font-family:"Calibri",sans-serif"><br>
<b>Subject:</b> Re: [CITE-Forum] WMS 1.1.1 exception<u></u><u></u></span></p>
<p class="MsoNormal"><u></u> <u></u></p>
<div>
<div>
<p class="MsoNormal">Hi !<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">I'm testing my WMS 1.1.1 service on <a href="http://cite.opengeospatial.org/te2" target="_blank">http://cite.opengeospatial.org/te2</a><u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">My service is accessible here : <a href="http://vpn.k2geospatial.com:9999/wms1_1/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetCapabilities" target="_blank">
http://vpn.k2geospatial.com:9999/wms1_1/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetCapabilities</a><u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">Two tests failed :<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">- Test wms:wmsops-getcapabilities-response-2 (View Details): Failed<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">I have created this issues on 4 Nov 2015 : <a href="https://github.com/opengeospatial/ets-wms11/issues/44" target="_blank">
https://github.com/opengeospatial/ets-wms11/issues/44</a><u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">And <u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">- Test wms:wmsops-getmap-each-srs (View Details): Failed<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">** detail **<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">Test wms:wmsops-getmap-each-srs type Mandatory default result Passed (s0022/d1e2113_1)<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">Assertion: For each SRS in the capabilities document, when a GetMap request uses the SRS, then the response is valid.<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">A sequence of more than one item is not allowed as the first argument of string() (<Name/>, <Name/>) <u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">Result: Failed<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">1 - Do you have news about <a href="https://github.com/opengeospatial/ets-wms11/issues/44" target="_blank">
https://github.com/opengeospatial/ets-wms11/issues/44</a> ?<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">2 - Can you help me to understand why Test wms:wmsops-getmap-each-srs fail ? I have no clue.<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">Thank you !<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">Etienne<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
</div>
</div></div></div>
</div>

</blockquote></div><br><br clear="all"><div><br></div>-- <br><div class="gmail_signature"><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><font face="Arial"><div style="font-size:small"><a href="http://k2geospatial.com/" style="font-weight:normal;color:rgb(17,85,204);font-family:'Lucida Grande',Verdana,Arial,sans-serif;font-size:11px;line-height:17px" target="_blank"><img src="http://images.k2geospatial.com/k2.png" alt="K2 Geospatial Logo" style="float:left;padding:4px 11px 0px 0px"></a><span style="color:rgb(0,0,0);font-family:'Lucida Grande',Verdana,Arial,sans-serif;font-size:11px;line-height:17px"><b>Etienne Moiroux</b></span><span style="font-weight:normal;color:rgb(0,0,0);font-family:'Lucida Grande',Verdana,Arial,sans-serif;font-size:11px;line-height:17px"> | D</span><span style="font-family:arial,sans-serif">éveloppeur</span><br style="color:rgb(0,0,0);font-family:'Lucida Grande',Verdana,Arial,sans-serif;font-size:11px;font-weight:normal;line-height:17px"><a href="tel:%28514%29%20285-1211%20ext.%20124" value="+15142851211" style="font-weight:normal;color:rgb(17,85,204);font-family:'Lucida Grande',Verdana,Arial,sans-serif;font-size:11px;line-height:17px" target="_blank">(514) 285-1211 ext. 113</a><span style="font-weight:normal;color:rgb(0,0,0);font-family:'Lucida Grande',Verdana,Arial,sans-serif;font-size:11px;line-height:17px"> | </span><span style="color:rgb(102,102,102);font-family:Arial,sans-serif;font-size:13px;white-space:nowrap"><a href="mailto:emoiroux@k2geospatial.com" target="_blank">emoiroux@k2geospatial.com</a></span><br style="color:rgb(0,0,0);font-family:'Lucida Grande',Verdana,Arial,sans-serif;font-size:11px;font-weight:normal;line-height:17px"><span style="font-weight:normal;color:rgb(0,0,0);font-family:'Lucida Grande',Verdana,Arial,sans-serif;font-size:11px;line-height:17px">740, rue Notre-Dame O, suite 1260, Montréal, QC, H3C 3X6</span><br></div></font></div></div></div></div></div></div></div></div></div></div></div></div></div></div></div></div>
</div>