<html>
  <head>
    <meta content="text/html; charset=windows-1252"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <br>
    -----BEGIN PGP SIGNED MESSAGE-----<br>
    Hash: SHA1<br>
    <br>
    Hi Sebastian,<br>
    <br>
    1. I created a QGIS Project using the testdata for OGC 1.3.0
    cite:Autos, ...<br>
    2. Then I loged into <a class="moz-txt-link-freetext" href="http://cite.opengeospatial.org/teamengine/">http://cite.opengeospatial.org/teamengine/</a><br>
    3. Created a session testing the WMS using OGC_Web Map Service
    (WMS)_1.3.0_r10<br>
    4. Run the test<br>
    <br>
    - -> when the test asks me "Does the image above depict a large
    diamond that fills the frame?"<br>
    I can not see the image. If i have a look at the src="" of the
    <img>-Tag i see that the test request used to fetch the image
    does not have the mandatory SERVICE parameter set.<br>
    Well, there might be WMS Servers that ignore that and return an
    image anyway (using SERVICE=WMS as fallback), but QGIS throws an
    exception (telling the user about the missing mandatory parameter)<br>
    the test suit should use URLs that are correct.<br>
    <br>
    Or am I missing something here?<br>
    <br>
    Marco<br>
    <br>
    <br>
    Am 04.11.2014 um 15:07 schrieb Sebastian Goerke:<br>
    <span style="white-space: pre;">> Hi Marco,<br>
      ><br>
      > for which testcase does this behaviour occur? There are/ were
      test<br>
      > cases where parameters are ommitted intentionally.<br>
      ><br>
      > Best regards<br>
      ><br>
      > Sebastian<br>
      ><br>
      > Am 04.11.2014 um 12:36 schrieb Marco Lechner - in medias res
      GmbH:<br>
      > > When testing my WMS for OGC conformity using the
      testdataset, I do<br>
      > > not see the "large diamond". But the reason seems to be
      a bug in<br>
      > > the testengine:<br>
      ><br>
      > > src does not send the mandatory SERVICE parameter:
      <img border="1"<br>
      > >
src="<a class="moz-txt-link-freetext" href="http://">http://</a><myip>/cgi-bin/qgis_mapserv.fcgi?MAP=<mymapfile>&VERSION=1.3.0&REQUEST=GetMap&LAYERS=cite%3ABasicPolygons&STYLES=&CRS=CRS:84&BBOX=-1,-1,1,1&WIDTH=300&HEIGHT=300&FORMAT=image%2Fjpeg"<br>
      ><br>
      ><br>
      > xmlns:tems="java:com.occamlab.te.web.MonitorServlet"<br>
      > > xmlns:tec="java:com.occamlab.te.TECore"<br>
      > >
xmlns:functions=<a class="moz-txt-link-rfc2396E" href="https://cite.opengeospatial.org/wms-1.3.0/src/ctl/functions.xml">"https://cite.opengeospatial.org/wms-1.3.0/src/ctl/functions.xml"</a><br>
      ><br>
      ><br>
      > xmlns:gen="java:com.occamlab.te.Generator"<br>
      > >
xmlns:interactive=<a class="moz-txt-link-rfc2396E" href="https://cite.opengeospatial.org/wms-1.3.0/src/ctl/interactive.xml">"https://cite.opengeospatial.org/wms-1.3.0/src/ctl/interactive.xml"</a><br>
      ><br>
      ><br>
      > xmlns:ctl=<a class="moz-txt-link-rfc2396E" href="http://www.occamlab.com/ctl">"http://www.occamlab.com/ctl"</a><br>
      > > xmlns:wms=<a class="moz-txt-link-rfc2396E" href="http://www.opengis.net/wms">"http://www.opengis.net/wms"</a><br>
      > > xmlns:xs=<a class="moz-txt-link-rfc2396E" href="http://www.w3.org/2001/XMLSchema">"http://www.w3.org/2001/XMLSchema"</a><br>
      > > xmlns:xlink=<a class="moz-txt-link-rfc2396E" href="http://www.w3.org/1999/xlink">"http://www.w3.org/1999/xlink"</a><br>
      > > xmlns:saxon=<a class="moz-txt-link-rfc2396E" href="http://saxon.sf.net/">"http://saxon.sf.net/"</a><br>
      > > xmlns:te=<a class="moz-txt-link-rfc2396E" href="http://www.occamlab.com/te">"http://www.occamlab.com/te"</a>><br>
      ><br>
      > > I guess this is a bug in the r10 of WMS 1.3 testsuite in
      team<br>
      > > engine 4.0.5<br>
      ><br>
      > > Marco<br>
      ><br>
      ><br>
      ><br>
      > > _______________________________________________
      CITE-Forum mailing<br>
      > > list <a class="moz-txt-link-abbreviated" href="mailto:CITE-Forum@lists.opengeospatial.org">CITE-Forum@lists.opengeospatial.org</a><br>
      > >
      <a class="moz-txt-link-freetext" href="https://lists.opengeospatial.org/mailman/listinfo/cite-forum">https://lists.opengeospatial.org/mailman/listinfo/cite-forum</a><br>
      ><br>
      ><br>
      > _______________________________________________<br>
      > CITE-Forum mailing list<br>
      > <a class="moz-txt-link-abbreviated" href="mailto:CITE-Forum@lists.opengeospatial.org">CITE-Forum@lists.opengeospatial.org</a><br>
      > <a class="moz-txt-link-freetext" href="https://lists.opengeospatial.org/mailman/listinfo/cite-forum">https://lists.opengeospatial.org/mailman/listinfo/cite-forum</a></span><br>
    <br>
    - -- <br>
    +++++++++++++++++++++++++++++++++<br>
    in medias res Gesellschaft für Informationstechnologie mbH<br>
    Dr. Marco Lechner<br>
    Schwimmbadstr. 2, 79100 Freiburg<br>
    Telefon +49 761 705 798 - 0<br>
    Direkt -107,  Fax -09<br>
    <a class="moz-txt-link-abbreviated" href="http://www.webgis.de">www.webgis.de</a><br>
    +++++++++++++++++++++++++++++++++<br>
    Geschäftsführer: Stefan Giese, Dr. Christof Lindenbeck<br>
    Eingetragen im Handelsregister HRB 5930 beim Amtsgericht Freiburg<br>
    +++++++++++++++++++++++++++++++++<br>
    Aufwind durch Wissen!<br>
    <br>
    Qualifizierte Open Source Schulungen bei der<br>
    Foss-Academy: <a class="moz-txt-link-abbreviated" href="http://www.foss-akademie.de/">www.foss-akademie.de/</a><br>
    +++++++++++++++++++++++++++++++++<br>
    <br>
    Hinweis zu Anhängen die auf .p7m oder .asc enden:<br>
    Die .p7m- und .asc-Dateien sind ungefährliche Signaturdateien
    (digitale Unterschriften).<br>
    In E-Mail-Clients mit S/MIME Konfiguration (.p7m) oder
    PGP-Erweiterung (.asc) dienen sie zur:<br>
    - - Überprüfung des Absenders<br>
    - - Überprüfung einer ev. Veränderung des Inhalts während der
    Übermittlung über das Internet<br>
    Die Signaturdateien können ebenso dazu verwendet werden dem Absender
    dieser Signatur eine E-Mail mit verschlüsseltem Inhalt zu senden.<br>
    <br>
    In E-Mail-Clients ohne S/MIME Konfiguration oder PGP-Erweiterung
    erscheinen die Dateien als Anhang und können ignoriert werden.<br>
    <br>
    -----BEGIN PGP SIGNATURE-----<br>
    Version: GnuPG v1<br>
    <br>
    iQEcBAEBAgAGBQJUWOg5AAoJEEd4P/hUvyR4Q3UH/3N43o0X7gQYneS/ghdmPX5a<br>
    ICSTHEaep90VZqEZE2b+zip6nR8pmLhlGnPI4R8MVYVM5BD4vqUSxfPgx2Pa5m2D<br>
    6mUp59znMyifNNOIO6eizn/WJPG4PNpBtoiLjtSE8XPBWThmHkmlhvPYHiP3G47C<br>
    SK232GR5i9EQ4wZypdftz3fC6G1CeVah+GLom8QHjfAoVWj8Jbq4qRKTBRY191YS<br>
    PKR4epy4kB50FVXD7c+SVYFS7Z9lfaPvBeoyInjazNgdLzvoZFpEyGUJ2ck/sLla<br>
    ef5U3bowcthhrOtPEPRxf+5Y5TMDhOfxFPKvZ7snSAF2dpb3BNySZLF5TVFTiuM=<br>
    =WJk6<br>
    -----END PGP SIGNATURE-----<br>
    <br>
  </body>
</html>