<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    Hi Richard,-<br>
    Thanks very much, the command line did not work but when i modified
    settings.xml for the proxy then "mvn install site" worked.<br>
    (The settings.xml was under apache-maven-3.0.5/conf but not .m2
    dir.)<br>
    <br>
    However, the Web Module had failed due to the
    maven-war-plugin-2.3.jar which was downloaded to be 0 bytes:<br>
    <br>
    ....long log....<br>
    <small>[INFO]
      ------------------------------------------------------------------------<br>
      [INFO] Building TEAM Engine - Web Module 4.0-beta2<br>
      [INFO]
      ------------------------------------------------------------------------<br>
      Downloading:
<a class="moz-txt-link-freetext" href="http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-war-plugin/2.3/maven-war-plugin-2.3.pom">http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-war-plugin/2.3/maven-war-plugin-2.3.pom</a><br>
      Downloaded:
      <a class="moz-txt-link-freetext" href="http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-war-plugin/2.3/maven-war-plugin-2.3.pom">http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-war-plugin/2.3/maven-war-plugin-2.3.pom</a>
      (8 KB at 26.5 KB/sec)<br>
      <u><b>[WARNING] The POM for
          org.apache.maven.plugins:maven-war-plugin:jar:2.3 is invalid,
          transitive dependencies (if any) will not be available, enable
          debug logging for more details</b></u><br>
      Downloading:
<a class="moz-txt-link-freetext" href="http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-war-plugin/2.3/maven-war-plugin-2.3.jar">http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-war-plugin/2.3/maven-war-plugin-2.3.jar</a><br>
      Downloaded:
      <a class="moz-txt-link-freetext" href="http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-war-plugin/2.3/maven-war-plugin-2.3.jar">http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-war-plugin/2.3/maven-war-plugin-2.3.jar</a>
      (82 KB at 44.3 KB/sec)<br>
      [INFO]
      ------------------------------------------------------------------------<br>
      [INFO] Reactor Summary:<br>
      [INFO] <br>
      [INFO] TEAM Engine ....................................... SUCCESS
      []<br>
      [INFO] TEAM Engine - Tomcat Realm ........................ SUCCESS
      []<br>
      [INFO] TEAM Engine - Shared Resources .................... SUCCESS
      []<br>
      [INFO] TEAM Engine - Service Providers ................... SUCCESS
      []<br>
      [INFO] TEAM Engine - Core Module ......................... SUCCESS
      []<br>
      [INFO] TEAM Engine - Web Module .......................... FAILURE
      []<br>
      [INFO]
      ------------------------------------------------------------------------<br>
      [INFO] BUILD FAILURE<br>
      [INFO]
      ------------------------------------------------------------------------<br>
      [INFO] Total time: s<br>
      [INFO] Finished at: Thu Apr 18 12:27:25 PDT 2013<br>
      [INFO] Final Memory: 34M/85M<br>
      [INFO]
      ------------------------------------------------------------------------<br>
      [ERROR] Failed to parse plugin descriptor for
      org.apache.maven.plugins:maven-war-plugin:2.3
      (<somedirectory>/.m2/repository/org/apache/maven/plugins/maven-war-plugin/2.3/maven-war-plugin-2.3.jar):
      error in opening zip file -> [Help 1]<br>
      [ERROR] <br>
      [ERROR] To see the full stack trace of the errors, re-run Maven
      with the -e switch.<br>
      [ERROR] Re-run Maven using the -X switch to enable full debug
      logging.<br>
      [ERROR] <br>
      [ERROR] For more information about the errors and possible
      solutions, please read the following articles:<br>
      [ERROR] [Help 1]
<a class="moz-txt-link-freetext" href="http://cwiki.apache.org/confluence/display/MAVEN/PluginDescriptorParsingException">http://cwiki.apache.org/confluence/display/MAVEN/PluginDescriptorParsingException</a><br>
    </small><br>
    Is there a way to run "mvn install site" only for the Web Module (or
    for a failed module at a time)?<br>
    <br>
    Best regards<br>
    baris<br>
    <br>
    <br>
    <div class="moz-cite-prefix">On 4/18/2013 1:22 PM, Richard Martell
      wrote:<br>
    </div>
    <blockquote
cite="mid:4E1D53230994FD45A119B5090DFBF46002C6475D@andalusia.Galdos.local"
      type="cite">
      <pre wrap="">Baris,


Hmm. Looks like an HTTP connection issue. Do you use a web proxy? 
Can you ping these hosts?

repo.maven.apache.org
svn.opengeospatial.org


If using a proxy server, you'll need to either modify your settings.xml 
($HOME/.m2/settings.xml) or pass in some system properties directly. 
See <a class="moz-txt-link-rfc2396E" href="http://maven.apache.org/guides/mini/guide-proxies.html"><http://maven.apache.org/guides/mini/guide-proxies.html></a>.

e.g.
</pre>
      <blockquote type="cite">
        <pre wrap="">mvn install -Dhttp.proxyHost=proxy_name -Dhttp.proxyPort=port_number
</pre>
      </blockquote>
      <pre wrap="">
--
Richard

</pre>
    </blockquote>
  </body>
</html>