<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content="text/html; charset=us-ascii" http-equiv=Content-Type>
<META name=GENERATOR content="MSHTML 8.00.6001.19154"></HEAD>
<BODY>
<DIV><FONT size=2 face=Arial><SPAN class=605445014-23082012>Hi 
all,</SPAN></FONT></DIV>
<DIV><FONT size=2 face=Arial><SPAN class=605445014-23082012></SPAN></FONT><FONT 
size=2 face=Arial><SPAN class=605445014-23082012></SPAN></FONT> </DIV>
<DIV><FONT size=2 face=Arial><SPAN class=605445014-23082012>Since the Web 
Service Common 2.0.0 states that service exceptions should use HTTP Status codes 
400, 500 and 501 I tested writing the same codes for our older 1.x interfaces 
too (WMS,WFS&WCS).</SPAN></FONT></DIV>
<DIV><FONT size=2 face=Arial><SPAN class=605445014-23082012>
<DIV><FONT size=2 face=Arial><SPAN 
class=605445014-23082012></SPAN></FONT> </DIV>
<DIV><FONT size=2 face=Arial><SPAN class=605445014-23082012>As far as I can tell 
the 1.x specifications don't say a whole lot about HTTP status 
codes. The 1.1.0 Web Service Common specification do have a test case 
A4.1.5 that kind of mentions that the status code for exceptions should be 
4xx/5xx in capabilities responses.</SPAN></FONT></DIV></SPAN></FONT></DIV>
<DIV><FONT size=2 face=Arial><SPAN 
class=605445014-23082012></SPAN></FONT> </DIV>
<DIV><FONT size=2 face=Arial><SPAN class=605445014-23082012>But when trying to 
run the online TEAM Engine test all these test fail with a java IOException 
because the response uses status codes other than 200. Is this by design or a 
bug?</SPAN></FONT></DIV>
<DIV><FONT size=2 face=Arial><SPAN class=605445014-23082012></SPAN></FONT><FONT 
size=2 face=Arial><SPAN class=605445014-23082012></SPAN></FONT> </DIV>
<DIV><FONT size=2 face=Arial><SPAN class=605445014-23082012>best 
regards,</SPAN></FONT></DIV>
<DIV><FONT size=2 face=Arial><SPAN class=605445014-23082012>Mats 
Olsson</SPAN></FONT></DIV></BODY></HTML>