Andreas,<br><br>Thanks a lot for looking into this, and I really appreciate it. I will try different things to see if I can workaround it.<br><br>Yingqi<br><br><div class="gmail_quote">On Thu, Feb 2, 2012 at 12:42 AM, Andreas Schmitz <span dir="ltr"><<a href="mailto:schmitz@lat-lon.de">schmitz@lat-lon.de</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Yingqi Tang wrote:<br>
<br>
Hi,<br>
<div class="im"><br>
> One more question, when you see it working, what version of JRE/JDK you're<br>
> using and also what web server you use to deploy the team engine? I can<br>
> probably try with those combination to see if I can reproduce the problem.<br>
> I still believe there is a double url encoding issue somewhere in test<br>
> engine, what happens to other services may be that some web server may<br>
> tolerate the double url encoded string.<br>
<br>
</div>I'm using the deegree implementation on Tomcat 6.0.29 with Java<br>
1.6.0_26:<br>
<br>
<a href="http://artefacts.deegree.org/libs-releases-local/org/deegree/deegree-compliance-tests/3.2-pre3/deegree-compliance-tests-3.2-pre3.war" target="_blank">http://artefacts.deegree.org/libs-releases-local/org/deegree/deegree-compliance-tests/3.2-pre3/deegree-compliance-tests-3.2-pre3.war</a><br>

<div class="im"><br>
> Can you try debugging into the first a few lines of "parse" method of<br>
> HTTPParser class of test engine and see what url is sent?<br>
<br>
</div>Attached is a screenshot. As you can see, eg. the CRS and LAYERS<br>
parameters are properly URL encoded, once.<br>
<br>
Best regards,<br>
Andreas<br>
<br>-----BEGIN PGP SIGNATURE-----<br>
Version: GnuPG v1.4.10 (GNU/Linux)<br>
<br>
iEYEARECAAYFAk8qTFUACgkQ737OVr+Ru7rVjQCguyaE51pVSyqQnGkOg0eJ/szA<br>
PkUAoLmXH7VILxgv1k3N3KJBolKppL+4<br>
=W8Pd<br>
-----END PGP SIGNATURE-----<br>
<br></blockquote></div><br>