[CITE-Forum] Issues while testing

Kaustubh.Chandorkar at igenesys.com Kaustubh.Chandorkar at igenesys.com
Mon Feb 20 13:44:42 EST 2017


Hi,
I am getting following errors:


            Testing basic_elements:negotiate-higher-version type Mandatory in Test Mode with defaultResult Pass (s0070/d1e17167_1/d1e496_1/d1e518_1)...

               Context: WMS_Capabilities element

               Assertion: When a GetCapabilities request is made for version 100.0.0, then the response is not lower than 1.3.0.

            Test basic_elements:negotiate-higher-version Failed



            Testing basic_elements:escaped-chars type Mandatory in Test Mode with defaultResult Pass (s0070/d1e17167_1/d1e498_1/d1e534_1)...

               Context: WMS_Capabilities element

               Assertion: The server can decode escaped hex values.

            Test basic_elements:escaped-chars Failed





Testing basic_elements:extra-GetFeatureInfo-param type Mandatory in Test Mode with defaultResult Pass (s0070/d1e17167_1/d1e500_1/d1e554_1)...

               Context: WMS_Capabilities element

               Assertion: When a GetFeatureInfo request contains a parameter which is not defined by the spec, the result is valid.

            Test basic_elements:extra-GetFeatureInfo-param Failed

         Test basic_elements:param-rules Failed

      Test basic_elements:main Failed - Inherited

   Test main:main Failed - Inherited

Suite wms-1.3.0:ets-wms13 Failed





Please help me to resolve this iisue.



Regards,

Kaustubh Ch











________________________________
From: Dirk Stenger [cite at lat-lon.de]
Sent: Friday, February 17, 2017 4:06 PM
To: Kaustubh Chandorkar; cite-forum at lists.opengeospatial.org
Subject: Re: [CITE-Forum] Issues while testing


Hi Kaustubh,


I tested your service several times on http://cite.opengeospatial.org/teamengine/ , but I was not able to reproduce the error.


Can you please check if the error is still occurring?


If this is the case, can you please describe the options you selected when starting the test?


Kind regards,

Dirk



Am 16.02.2017 um 16:44 schrieb Kaustubh.Chandorkar at igenesys.com<mailto:Kaustubh.Chandorkar at igenesys.com>:
Hi,

Any findings?

I have taken all the test data (shape file).

Giving names as per the document e.g cite:Autos (Layer title) , cite:BasicPolygons etc

Capabilities Setup :
http://forums.igenesys.com/iGenVision/cite/wms?service=WMS&request=GetCapabilities&version=1.3.0

What's going wrong?

Regards,
Kaustubh Ch.

________________________________
From: Kaustubh Chandorkar
Sent: Tuesday, February 14, 2017 2:34 PM
To: Dirk Stenger; cite-forum at lists.opengeospatial.org<mailto:cite-forum at lists.opengeospatial.org>
Subject: RE: [CITE-Forum] Issues while testing

Hi,

Almost 7 to 8 times.

Regards,
Kaustubh Ch.

________________________________
From: CITE-Forum [cite-forum-bounces at lists.opengeospatial.org<mailto:cite-forum-bounces at lists.opengeospatial.org>] On Behalf Of Dirk Stenger via CITE-Forum [cite-forum at lists.opengeospatial.org<mailto:cite-forum at lists.opengeospatial.org>]
Sent: Tuesday, February 14, 2017 2:26 PM
To: cite-forum at lists.opengeospatial.org<mailto:cite-forum at lists.opengeospatial.org>
Subject: Re: [CITE-Forum] Issues while testing


Hi Kaustubh,


can you estimate how many times out of ten this error is occurring?

Does it always occur with the same tested WMS service?


Kind regards,

Dirk



Am 14.02.2017 um 05:04 schrieb Kaustubh.Chandorkar--- via CITE-Forum:
Hi All,

Greetings.
We are facing issues while testing WMS. Please see attached screenshots.
Sometimes below error is coming:

Test basic_elements:main type Mandatory default result Passed (s0003/d1e17167_1)
Assertion: The basic service elements behave properly.
Context:
   Label:
   Value: WMS_Capabilities element
Subtest name basic_elements:version-negotiation type Mandatory path s0003/d1e17167_1/d1e496_1 result Failed (InheritedFailure)
Subtest name basic_elements:reserved-chars type Mandatory path s0003/d1e17167_1/d1e498_1 result Failed (InheritedFailure)
Subtest name basic_elements:param-rules type Mandatory path s0003/d1e17167_1/d1e500_1 result Passed
Result: Failed (InheritedFailure)

Please help.

Regards,
Kaustubh Ch

________________________________
DISCLAIMER

This communication (including any accompanying documents) is intended only for the use of the addressee(s) and contains information that is PRIVILEGED AND CONFIDENTIAL. Unauthorized reading, dissemination, distribution or copying of this communication is prohibited. If you have received this communication in error, please promptly destroy the original communication and all copies taken thereof. Any views expressed in this message are those of the individual sender, except where the sender specifically states them to be the views of his/her company. Our company does not represent, warrant and/or guarantee that the integrity of this message has been maintained or that the communication is free of errors, virus, interception or interference.



_______________________________________________
CITE-Forum mailing list
CITE-Forum at lists.opengeospatial.org<mailto:CITE-Forum at lists.opengeospatial.org>
https://lists.opengeospatial.org/mailman/listinfo/cite-forum



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20170221/4082d0f7/attachment.html>


More information about the CITE-Forum mailing list