[CITE-Forum] Issues during OGC test

Kaustubh.Chandorkar at igenesys.com Kaustubh.Chandorkar at igenesys.com
Mon Aug 1 04:22:44 EDT 2016


Hi ,

We are facing issues during OGC test.



We have tried both the sites for ogc test :
 http://cite.opengeospatial.org/teamengine/
 http://cite.opengeospatial.org/te2/

GeoServer details :
          1. GeoServer version -  2.9
          2. WMS version         - 1.3
          3. Dataset (test dataset): http://cite.opengeospatial.org/te2/about/wms/1.3.0/site/



For testing services we are using OGC validator test suite - Web Map Service (WMS) version 1.16.

Capabilities Setup :
http://forums.igenesys.com/geoserverogc/cite/wms?service=WMS&request=GetCapabilities&version=1.3.0

 These are the options I am selecting in the validator website:

UpdateSequence Values : Automatic - The updateSequence tests will use automatically generated updateSequence values

Options : BASIC - Test basic functionality that depends on the CITE dataset. This option is required for certification.
               QUERYABLE - Test GetFeatureInfo functionality that depends on the CITE dataset.

Everytime it asks below questions :

1. Does the image above depict a large diamond that fills the frame?
2. Does the image above depict a map of the Blue Lake vicinity with a surrounding neatline?
3. In the picture on the left, Goose Island, Blue Lake, and Ashton should overlay State Forest. In the picture on the right, State Forest should be on top of Ashton, Blue Lake, and Goose Island. Are the  pictures correct?
4. The two pictures above should depict the same scene, but the picture on the right should be stretched so it is twice as tall as the picture on the left. Are the pictures correct?
5. Does the image above contain an error message indicating that the layer requested was not defined?

But during these questions there is no image displays on the screen.
 If We have a look at the src="" of the <img src> -Tag we see that the test request used to fetch the image does not have the mandatory SERVICE parameter set.

Please let us know what to do in this case.

Regards,
Kaustubh

________________________________
DISCLAIMER

This communication (including any accompanying documents) is intended only for the use of the addressee(s) and contains information that is PRIVILEGED AND CONFIDENTIAL. Unauthorized reading, dissemination, distribution or copying of this communication is prohibited. If you have received this communication in error, please promptly destroy the original communication and all copies taken thereof. Any views expressed in this message are those of the individual sender, except where the sender specifically states them to be the views of his/her company. Our company does not represent, warrant and/or guarantee that the integrity of this message has been maintained or that the communication is free of errors, virus, interception or interference.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20160801/a30b19b9/attachment.html>


More information about the CITE-Forum mailing list