[CITE-Forum] WMS 1.1.1 exception

Étienne Moiroux emoiroux at k2geospatial.com
Wed Apr 13 11:05:54 EDT 2016


Hi,

Thank you for the quick reply !
Everything is fine know.
All tests pass for WMS 1.3 and 1.1.1.

Cordially,
Etienne

2016-04-07 19:10 GMT-04:00 Richard Martell <rmartell at galdosinc.com>:

> Étienne,
>
>
>
> Three tests fail.
>
>
>
> 1. wmsops-getcapabilities-response-2
>
>
>
> There are several validation errors: “The content of element type "Layer"
> must match "(Name?,Title,Abstract?,…”
>
> Note that Title must follow Name.
>
>
>
>
>
> 2. wmsops-getmap-each-layer
>
>
>
> This failed due to an unexpected content type:
> “application/vnd.ogc.se_xml;charset=utf-8”.
>
> Reports “The coordinate system is not defined”, and the SRS param is empty
> in the request URI.
>
>
>
> However, the requested layer is “wms1.1.1” which is actually the root
> layer. You should remove the Name from the root layer, since it’s generally
> not a named layer that can be requested.
>
>
>
>
>
> 3.  wmsops-getmap-each-srs
>
>
>
> A sequence of more than one item is not allowed as the first argument of
> string() (<Name/>, <Name/>)
>
>
>
> Two named layers are identified here because the root layer has a Name.
> Remove that and this should work.
>
>
>
> --
>
> Richard
>
>
>
>
>
> *From:* CITE-Forum [mailto:cite-forum-bounces+rmartell=
> galdosinc.com at lists.opengeospatial.org] *On Behalf Of *Richard Martell
> via CITE-Forum
> *Sent:* Thursday, 07 April, 2016 10:58
> *To:* Étienne Moiroux <emoiroux at k2geospatial.com>; Luis Bermudez <
> lbermudez at opengeospatial.org>
> *Cc:* cite-forum at lists.opengeospatial.org
>
> *Subject:* Re: [CITE-Forum] WMS 1.1.1 exception
>
>
>
> Hi Étienne,
>
>
>
> I observed more failing tests--the service may be misconfigured. For
> example, this request is submitted in test ‘wmsops-getmap-params-bbox-1’;
> the response is expected to be an image: “Does the image above depict a
> large diamond that fills the frame?”.
>
>
>
> <
> http://vpn.k2geospatial.com:9999/wms1_1/wms?VERSION=1.1.1&REQUEST=GetMap&LAYERS=cite:BasicPolygons&STYLES=&SRS=EPSG:4326&BBOX=-1,-1,1,+1&WIDTH=400&HEIGHT=400&FORMAT=image/png
> >
>
>
>
> The response includes an exception report:
>
>
>
> <ServiceExceptionReport>
>
>     <ServiceException>
>
> class "com.kheops.jmap.server.wms.WmsGetMapRequestUtil"'s signer
> information does not match signer information of other classes in the same
> package
>
> </ServiceException>
>
> </ServiceExceptionReport>
>
>
>
>
>
> --
>
> Richard
>
>
>
>
>
> *From:* Étienne Moiroux [mailto:emoiroux at k2geospatial.com
> <emoiroux at k2geospatial.com>]
> *Sent:* Tuesday, 05 April, 2016 12:44
> *To:* Luis Bermudez <lbermudez at opengeospatial.org>
> *Cc:* Richard Martell <rmartell at galdosinc.com>;
> cite-forum at lists.opengeospatial.org
> *Subject:* Re: [CITE-Forum] WMS 1.1.1 exception
>
>
>
> Hi !
>
>
>
> I'm testing my WMS 1.1.1 service on http://cite.opengeospatial.org/te2
>
>
>
> My service is accessible here :
> http://vpn.k2geospatial.com:9999/wms1_1/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetCapabilities
>
>
>
> Two tests failed :
>
>
>
> - Test wms:wmsops-getcapabilities-response-2 (View Details): Failed
>
> I have created this issues on 4 Nov 2015 :
> https://github.com/opengeospatial/ets-wms11/issues/44
>
>
>
> And
>
>
>
> - Test wms:wmsops-getmap-each-srs (View Details): Failed
>
> ** detail **
>
> Test wms:wmsops-getmap-each-srs type Mandatory default result Passed
> (s0022/d1e2113_1)
>
> Assertion: For each SRS in the capabilities document, when a GetMap
> request uses the SRS, then the response is valid.
>
> A sequence of more than one item is not allowed as the first argument of
> string() (<Name/>, <Name/>)
>
> Result: Failed
>
>
>
> 1 - Do you have news about
> https://github.com/opengeospatial/ets-wms11/issues/44 ?
>
> 2 - Can you help me to understand why Test wms:wmsops-getmap-each-srs fail
> ? I have no clue.
>
>
>
> Thank you !
>
> Etienne
>
>
>



-- 
[image: K2 Geospatial Logo] <http://k2geospatial.com/>*Etienne Moiroux* | D
éveloppeur
(514) 285-1211 ext. 113 <%28514%29%20285-1211%20ext.%20124> |
emoiroux at k2geospatial.com
740, rue Notre-Dame O, suite 1260, Montréal, QC, H3C 3X6
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20160413/2bed163d/attachment.html>


More information about the CITE-Forum mailing list