[CITE-Forum] Fwd: functions.ctl not found

saurabh kumar saurabhk.vizexperts at gmail.com
Wed Apr 13 02:43:05 EDT 2016


Hi,

I'm testing WFS through ogc test and some of the test cases are getting
failed and i'm not able to find any solution.

Test cases failed

a) wfs:wfs-1.1.0-Basic-GetCapabilities-tc7

 Resuest :
http://localhost:19090/maps?version=1.1.0#request=GetCapabilities,service=WFS
 Assertion: A valid http URL value shall conform to the syntax specified in
RFC 2616. http_URL = 'http:' '//' host [
  ':' port ] [ abs_path [ '?' query ]]

 ERROR : Messages from parser p:XMLValidatingParser.GMLSF1:
         Validation error:
         cvc-elt.1.a: Cannot find the declaration of element 'HTML'.
b) wfs:wfs-1.1.0-Basic-GetCapabilities-tc13

 Request :
http://localhost:19090/maps?&version=1.1.0&request=GetCapabilities
 Error in call to extension function {public org.w3c.dom.NodeList
com.occamlab.te.TECore.request(org.w3c.dom.Document,java.lang.String)
throws java.lang.Throwable}: Exception in extension function
java.lang.reflect.InvocationTargetException
 Result: Failed
c) wfs:wfs-1.1.0-Basic-DescribeFeatureType-POST-tc1

Assertion: The following attributes are required for all XML request
entities: @version (default '1.1.0');
  @service (default 'WFS').
 Messages from parser p:XMLValidatingParser.XMLSchema:
Validation error:
     cvc-datatype-valid.1.2.1: ':BasicPolygonsType' is not a valid value
for 'QName'.
Validation error:
      cvc-attribute.3: The value ':BasicPolygonsType' of attribute 'type'
on element 'element' is not valid with respect to its type, 'QName'.

Where BasicPolygons is a vector layer name.




There are few test cases which are getting failed and i'm not able to find
any solution for the same.

1) WMS(1.3.0) - Test cases failed

a) getmap:bbox-pixel-interpretation

  Request :
http://localhost:19090/maps?&StYlEs=&HeIgHt=7&CrS=CRS:84&BbOx=0.0016,-0.0012,0.0026,-0.0005&WiDtH=10&FoRmAt=image%2Fpng&ReQuEsT=GetMap&VeRsIoN=1.3.0&LaYeRs=cite:Lakes

  Assertion: The server interprets the bounding box as going around the
"outside" of the pixels of the image rather than through the
centers of the border pixels.
b) getfeatureinfo:query_layers-not-queryable

 Request :
http://localhost:19090/maps?&LaYeRs=MS&ReQuEsT=GetFeatureInfo&BbOx=-90,-180,90,180&WiDtH=100&CrS=EPSG%3A4326&QuErY_LaYeRs=MS&VeRsIoN=1.3.0&StYlEs=&I=50&J=50&HeIgHt=100&InFo_fOrMaT=text%2Fhtml&FoRmAt=image%2Fpng
 Assertion: When GetFeatureInfo is requested on a Layer that is not
queryable, then the server issues a Service Exception
(code=LayerNotQueryable).


 I'm testing wcs(2.0.1) through ogc compliance test and some of the test
cases are getting failed with an error : The server does not support the
gml coverage.

Test case id : cs2:get-kvp-core-req12

Assertion: req12: For all WCS request types, test the request version
parameter has     a fixed value of '2.0.1' by GetKVP.
Message d9183e2208_1: [MESSAGE] The server does not support the gml
coverage.

Result: Failed

Any suggestions to solve this issue.

Thanks
Saurabh kumar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20160413/088c8957/attachment-0001.html>


More information about the CITE-Forum mailing list