[CITE-Forum] Test case s0022/d711e387_1/d1794e39_1/d1794e142_1

Christine Bao Christine.Bao at autodesk.com
Tue Apr 12 02:27:25 EDT 2016


Hi Richard,

Would you please check the below error? The whole test cases have pass except this one. It's much appreciated!

Thanks & regards,
Christine

From: Christine Bao
Sent: Friday, April 08, 2016 12:16 PM
To: 'Richard Martell'; 'cite-forum at lists.opengeospatial.org'
Subject: RE: Test case s0022/d711e387_1/d1794e39_1/d1794e142_1

WMS 1.1.1 test passes, attached is the log file.

From: Christine Bao
Sent: Friday, April 08, 2016 12:09 PM
To: 'Richard Martell'; cite-forum at lists.opengeospatial.org
Subject: Test case s0022/d711e387_1/d1794e39_1/d1794e142_1

Hi Richard,

Would you please check your engine's test case s0022/d711e387_1/d1794e39_1/d1794e142_1? It seems the check condition is not correct. The test case is for WMS 1.3.0, Path: Test main:main<http://cite.opengeospatial.org/teamengine/listings/srv_local_teamengine-prod_TE_BASE_scripts_wms_1.3.0_ctl_main.html#main:main>/ Test getmap:main<http://cite.opengeospatial.org/teamengine/listings/srv_local_teamengine-prod_TE_BASE_scripts_wms_1.3.0_ctl_getmap.html#getmap:main>/ Test getmap:crs<http://cite.opengeospatial.org/teamengine/listings/srv_local_teamengine-prod_TE_BASE_scripts_wms_1.3.0_ctl_getmap.html#getmap:crs>/ Test getmap:crs-direct<http://cite.opengeospatial.org/teamengine/listings/srv_local_teamengine-prod_TE_BASE_scripts_wms_1.3.0_ctl_getmap.html#getmap:crs-direct>. My test result shows:

Log for test s0022/d711e387_1/d1794e39_1/d1794e142_1
Test getmap:crs-direct type Mandatory default result Passed (s0022/d711e387_1/d1794e39_1/d1794e142_1)

Assertion: When a GetMap request contains a single layer and a CRS where the CRS is contained directly in the layer in the capabilities document, then the response is valid.

Context:
   Label:
   Value: WMS_Capabilities element

Request d1794e1946_1:
   Method: get
   URL: http://ec2-54-176-33-158.us-west-1.compute.amazonaws.com:8808/mapserver2017/mapagent/mapagent.fcgi?&LaYeRs=CITEWMS%2FLayers%2FBasicPolygons&BbOx=2,-2,2,6&CrS=EPSG%3A4326&WiDtH=200&FoRmAt=image%2Fpng&HeIgHt=200&VeRsIoN=1.3.0&StYlEs=&ReQuEsT=GetMap
   Response from parser parsers:HTTPParser:
      <response>
   <status code="200" protocol="HTTP/1.1">OK</status>
   <headers>
      <header name="Date">Thu, 07 Apr 2016 10:03:18 GMT</header>
      <header name="Server">Apache/2.4.10 (Win64) PHP/5.5.17 mod_jk/1.2.40</header>
      <header name="Status">200 OK</header>
      <header name="Content-Length">523</header>
      <header name="Keep-Alive">timeout=15, max=90</header>
      <header name="Connection">Keep-Alive</header>
     <header name="Content-Type">text/xml; charset=utf-8</header>
   </headers>
   <content/>
   <!--Response received in [80] milliseconds--></response>

Result: Failed


The Get request http://ec2-54-176-33-158.us-west-1.compute.amazonaws.com:8808/mapserver2017/mapagent/mapagent.fcgi?&LaYeRs=CITEWMS%2FLayers%2FBasicPolygons&BbOx=2,-2,2,6&CrS=EPSG%3A4326&WiDtH=200&FoRmAt=image%2Fpng&HeIgHt=200&VeRsIoN=1.3.0&StYlEs=&ReQuEsT=GetMap returns an exception:

<ServiceExceptionReport version="1.3.0" xsi:schemaLocation="http://www.opengis.net/ogc http://schemas.opengis.net/wms/1.3.0/exceptions_1_3_0.xsd<http://www.opengis.net/ogc%20http:/schemas.opengis.net/wms/1.3.0/exceptions_1_3_0.xsd>"><ServiceException code="InvalidBoundingBox">
  The bounding box for the map must be specified using four numerical values in the order: minX,minY,maxX,maxY. (Found BBOX=2,-2,2,6)
</ServiceException></ServiceExceptionReport>

However your check condition requires it should return an image, see http://cite.opengeospatial.org/teamengine/listings/srv_local_teamengine-prod_TE_BASE_scripts_wms_1.3.0_ctl_getmap.html#getmap:crs-direct


               <xsl:if test="functions:mime-match($response/response/headers/header[functions:to-lowercase(@name) = 'content-type'], $image-format) = 'false'">

                  <ctl:fail/>

               </xsl:if>

It may relate to another issue, attached the email.

Thanks & regards,
Christine

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20160412/bd12f818/attachment.html>


More information about the CITE-Forum mailing list