[CITE-Forum] WMS 1.1.1 exception

Étienne Moiroux emoiroux at k2geospatial.com
Tue Apr 5 15:44:11 EDT 2016


Hi !

I'm testing my WMS 1.1.1 service on http://cite.opengeospatial.org/te2

My service is accessible here :
http://vpn.k2geospatial.com:9999/wms1_1/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetCapabilities

Two tests failed :

- Test wms:wmsops-getcapabilities-response-2 (View Details): Failed
I have created this issues on 4 Nov 2015 :
https://github.com/opengeospatial/ets-wms11/issues/44

And

- Test wms:wmsops-getmap-each-srs (View Details): Failed
** detail **
Test wms:wmsops-getmap-each-srs type Mandatory default result Passed
(s0022/d1e2113_1)
Assertion: For each SRS in the capabilities document, when a GetMap request
uses the SRS, then the response is valid.
A sequence of more than one item is not allowed as the first argument of
string() (<Name/>, <Name/>)
Result: Failed

1 - Do you have news about
https://github.com/opengeospatial/ets-wms11/issues/44 ?
2 - Can you help me to understand why Test wms:wmsops-getmap-each-srs fail
? I have no clue.

Thank you !
Etienne


2015-10-28 15:17 GMT-04:00 Luis Bermudez <lbermudez at opengeospatial.org>:

> Hi Richard
> Thank you for responding.
>
> Hi Etienne
>
> The link to GitHub issue related to the old issue 923  is here:
> https://github.com/opengeospatial/ets-wms11/issues/22
>
> Here are the release notes:
> http://opengeospatial.github.io/ets-wms11/relnotes.html
>
>
> Luis Bermudez, Ph.D.
> Executive Director Compliance and E-Learning
> Open Geospatial Consortium (OGC)
> Skype: bermudez_luis
> Twitter: @berdez
> Tel: +1 301 760 7323
> https://www.linkedin.com/in/bermudez
>
> The OGC: Making Location Count
>
> On Oct 28, 2015, at 1:12 PM, Richard Martell via CITE-Forum <
> cite-forum at lists.opengeospatial.org> wrote:
>
> Étienne,
>
>
>
> This error almost always indicates that a binary resource (i.e. an image)
> was returned in the message body when an exception report was expected. As
> a result, the test results are malformed because of the way the binary
> content is serialized (by the XML parser).
>
>
>
> This seemed to happen a handful of times:
>
>
>
> * wmsops-getmap-params-bbox-5
>
> * wmsops-getmap-params-bbox-6
>
> * wmsops-getmap-params-bbox-7
>
> * wmsops-getmap-params-bbox-8
>
> * wmsops-getmap-params-styles-10
>
> * wmsops-getmap-params-styles-5
>
>
>
>
>
> BTW, the old CITE issue tracker was abandoned a while ago. Issues are now
> reported at GitHub:
>
> <https://github.com/opengeospatial/ets-wms11/issues>
>
>
>
> --
>
> Richard
>
>
>
>
>
> *From:* CITE-Forum [
> mailto:cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial.org
> <cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial.org>] *On
> Behalf Of *Étienne Moiroux via CITE-Forum
> *Sent:* Wednesday, 28 October, 2015 07:44
> *To:* cite-forum at lists.opengeospatial.org
> *Subject:* [CITE-Forum] Fwd: WMS 1.1.1 exception
>
>
>
> Hi,
>
>
>
> An exception appears on te2 WMS 1.1.1 Revision 1.10
>
>
>
> *Last request received *:
> http://vpn.k2geospatial.com:9999/wms1_1_1/wms?LaYeRs=cite%3ALakes&SrS=NONE&BbOx=0,-0.0020,0.0040,0&WiDtH=100&ReQuEsT=GetMap&StYlEs=&HeIgHt=100&FoRmAt=image%2Fpng&VeRsIoN=1.1.1
>
> *Error *: net.sf.saxon.trans.XPathException:
> org.xml.sax.SAXParseException; lineNumber: 38; columnNumber: 38; Character
> reference "&#26" is an invalid XML character
>
>
>
> You can used my WMS service if want to debug.
>
>
>
> *WMS serveur* :
> http://vpn.k2geospatial.com:9999/wms1_1_1/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetCapabilities
>
>
>
> Please see attached files.
>
>
>
> Note : The bug look like :
> https://portal.opengeospatial.org/services/srv_public_issues.php?call=viewIssue&issue_id=923
>
>
>
> Any work around ? My  Response Headers content-Type
> is text/xml;charset=UTF-8
>
> I don't understand what's wrong...
>
>
>
> Thank,
>
> Etienne
>
>
> _______________________________________________
> CITE-Forum mailing list
> CITE-Forum at lists.opengeospatial.org
> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
>
>
>


-- 
[image: K2 Geospatial Logo] <http://k2geospatial.com/>*Etienne Moiroux* | D
éveloppeur
(514) 285-1211 ext. 113 <%28514%29%20285-1211%20ext.%20124> |
emoiroux at k2geospatial.com
740, rue Notre-Dame O, suite 1260, Montréal, QC, H3C 3X6
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20160405/29e9e7aa/attachment.html>


More information about the CITE-Forum mailing list