[CITE-Forum] DTD and empty SRS

Dirk Stenger cite at lat-lon.de
Thu Oct 29 12:41:42 EDT 2015


Hi Etienne,

regarding Test : wms:wmsops-getmap-each-layer failed:

The SRS is empty because the root layer is selected for this test
(correct, as the root layer is requestable), but when the SRS is
determined, the root layer is not considered anymore. This leads to the
fact that no SRS can be found and the request is send without SRS.

There are two solutions:
1. You could remove the Name element from the root layer, so that it is
not requestable anymore. Then, the test should not fail anymore.
2. The test suite can be fixed. If you prefer this solution, please
create a ticket in https://github.com/opengeospatial/ets-wms11/issues
describing the problem.

Kind regards,
Dirk



Am 29.10.2015 um 15:15 schrieb Étienne Moiroux via CITE-Forum:
> Hi, 
>
> Here are some problems i have :
>
> Service :
> http://vpn.k2geospatial.com:9999/wms1_1_1/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetCapabilities
> Platform : http://cite.opengeospatial.org/te2
> Service : WMS 1.1.1 rev.1.10
>
> Test : wms:wmsops-getcapabilities-response-2 failed.
> Cause : wrong DTD ?
> Possibly related problem :
> https://github.com/opengeospatial/ets-wms11/issues/2 but i'm using
> http://schemas.opengis.net/wms/1.1.1/capabilities_1_1_1.dtd
>
> Test : wms:wmsops-getmap-each-layer failed.
> Cause : SrS is empty in the request.
> Possibly related problem :
> https://github.com/opengeospatial/ets-wms13/issues/6
>
> If you can help me i really appreciate.
>
> Thanks, 
> Etienne
>
> -- 
> *
> *Etienne Moiroux
> *Développeur
>
> 740, Rue Notre-Dame Ouest, bureau 1260
> Montréal (Québec) H3C 3X6
> Téléphone : (514) 285-1211 # 113
> Télécopie : (514) 285-1177
> Courriel : *_emoiroux at k2geospatial.com <mailto:akiss at k2geospatial.com>_*_
> http://www.k2geospatial.com <http://www.k2geospatial.com/>
> _ Suivez-nous sur LinkedIn <http://www.linkedin.com/company/k-g-eospatial>
>  Suivez-nous sur Twitter <http://www.twitter.com/k2geospatial>
> **__*
>
>
> _______________________________________________
> CITE-Forum mailing list
> CITE-Forum at lists.opengeospatial.org
> https://lists.opengeospatial.org/mailman/listinfo/cite-forum

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20151029/d018835a/attachment.html>


More information about the CITE-Forum mailing list