[CITE-Forum] Exception in extension function java.lang.IllegalArgumentException

Richard Martell rmartell at galdosinc.com
Tue May 27 12:14:01 EDT 2014


WFS developers,

The DescribeFeatureType request must be implemented by a conforming WFS, so make sure that there is an ows:Operation entry for it in the capabilities document. The test suite will attempt to fetch the GML application schema(s), and if this fails then an exception occurs.

I will add some early "sanity checks" for capabilities doc content so a more meaningful diagnostic message is produced.

--
Richard


From: CITE-Forum [mailto:cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial.org] On Behalf Of Richard Martell
Sent: Monday, 26 May, 2014 10:52
To: Joaquin Cabello; cite-forum at lists.opengeospatial.org
Subject: Re: [CITE-Forum] Exception in extension function java.lang.IllegalArgumentException

Hi Joaquin,

What version of the WFS2 test suite are you using? The latest release at http://cite.opengeospatial.org/te2/?

Is the service endpoint publicly accessible? If not, perhaps you could provide a copy of the capabilities document
(or send it to me directly if you prefer).

--
Richard


From: CITE-Forum [mailto:cite-forum-bounces at lists.opengeospatial.org] On Behalf Of Joaquin Cabello
Sent: Friday, 23 May, 2014 09:14
To: cite-forum at lists.opengeospatial.org<mailto:cite-forum at lists.opengeospatial.org>
Subject: [CITE-Forum] Exception in extension function java.lang.IllegalArgumentException

Hi all,

This is my first entry in this forum.

We are trying to run  TestNG tests for WFS 2.0.0 to check our product in terms of OGC compliance.
When I run the tests against the getCapabilities sample provided by  OGC (http://cite.lat-lon.de/deegree-webservices-3.3.6/services/wfs200?service=WFS&version=2.0.0&request=GetCapabilities) I get a report and it just runs perfect, but when I run the test using our getCapabilities xml file (also tried using the URL) we get an exception I've been trying to track down with no success.

Error in call to extension function {public java.lang.Object com.occamlab.te.TECore.callFunction(net.sf.saxon.expr.
XPathContext,java.lang.String,java.lang.String,net.sf.saxon.om.NodeInfo) throws java.lang.Exception}: Exception in
extension function net.sf.saxon.s9api.SaxonApiException: Error in call to extension function {public javax.xml.tran
sform.Source org.opengis.cite.iso19142.TestNGController.doTestRun(org.w3c.dom.Document) throws java.lang.Exception}
: Exception in extension function java.lang.IllegalArgumentException: Required parameters not found
   Test tns:Main Failed

Could somebody give us a hand here, please?

You can find the complete exception in the text file attached.

Kind regards,

Joaquin Cabello

________________________________
Avitech GmbH
Principal Office: Bahnhofplatz 1 | 88045 Friedrichshafen | Germany
Court Registration: Amtsgericht Ulm | HRB 728293
Geschäftsführer/Managing Director: Antonio Maria Gonzalez Gorostiza
VAT No.: DE223719716
http://avitech.aero
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20140527/f78deacd/attachment.html>


More information about the CITE-Forum mailing list