[CITE-Forum] Failed OGC WMS Test

Sebastian Goerke goerke at lat-lon.de
Wed Jun 11 13:43:45 EDT 2014


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi Bruce,

I fixed several of such issues within the last months. So my question
is, with which version of the tests / teamengine did you do the
testruns? Or have you used the online teamengine facilities from OGC?

Best regards

Sebastian

Am 11.06.2014 19:27, schrieb Bruce Dietrich:
> Below is a portion of the GetCapabilities response.  Each layer
> contains the same style element.  Is this the cause?   Should this
> be allowed?
> 
> <Layer queryable="1" opaque="0" cascaded="0"> 
> <Name>cite:BasicPolygons</Name> <Title>cite:BasicPolygons</Title> 
> <Abstract>ESRI Shapefile</Abstract> <SRS>EPSG:4326</SRS> 
> <LatLonBoundingBox minx="-2.000000000000" miny="-1.000000000000"
> maxx="2.000000000000" maxy="6.000000000000"/> <BoundingBox
> SRS="EPSG:4326" minx="-2.000000000000" miny="-1.000000000000"
> maxx="2.000000000000" maxy="6.000000000000" resx="4.000000000000"
> resy="7.000000000000"/> <Style> <Name>DEFAULT</Name> <Title>Default
> Style</Title> <Abstract>Default Style</Abstract> </Style> </Layer> 
> <Layer queryable="1" opaque="0" cascaded="0"> 
> <Name>cite:Bridges</Name> <Title>cite:Bridges</Title> 
> <Abstract>ESRI Shapefile</Abstract> <SRS>EPSG:4326</SRS> 
> <LatLonBoundingBox minx="0.000199000000" miny="0.000699000000"
> maxx="0.000201000000" maxy="0.000701000000"/> <BoundingBox
> SRS="EPSG:4326" minx="0.000199000000" miny="0.000699000000"
> maxx="0.000201000000" maxy="0.000701000000" resx="0.000002000000"
> resy="0.000002000000"/> <Style> <Name>DEFAULT</Name> <Title>Default
> Style</Title> <Abstract>Default Style</Abstract> </Style> </Layer>
> 
> 
> ----- Original Message ----- From: "Richard Martell"
> <rmartell at galdosinc.com> To: "Bruce Dietrich"
> <dietrichb at pixia.com>, cite-forum at lists.opengeospatial.org Sent:
> Wednesday, June 11, 2014 11:05:50 AM Subject: RE: [CITE-Forum]
> Failed OGC WMS Test
> 
> Bruce,
> 
> An error like that usually indicates that an XPath function was fed
> an invalid argument. This could be because:
> 
> a) The capabilities doc is valid but the script doesn't allow for
> multiple occurrences of some element (i.e. a script error); or b)
> The capabilities doc is not valid.
> 
> There is a direct call to the string() function in that test to
> find the "preferred-name" for a layer:
> 
> string($capabilities/Capability//Layer[Name and Style =
> $style]/Name)
> 
> So it looks like multiple layers were matched but this was not
> expected in the script.
> 
> -- Richard
> 
> 
> -----Original Message----- From: CITE-Forum
> [mailto:cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial.org]
> On Behalf Of Bruce Dietrich Sent: Wednesday, 11 June, 2014 07:19 
> To: cite-forum at lists.opengeospatial.org Subject: [CITE-Forum]
> Failed OGC WMS Test
> 
> I am running OGC WMS testing for WMS version 1.1.1 against our WMS
> service.  I am getting a failure for a single test (results shown
> below).  This test does not execute a web request against our
> service (no URL is generated by the OGC Test) and the error is
> cryptic.  What does this error mean?  What part of our
> GetCapabilities XML could cause this error?
> 
> ==================================== Log for test s0001/d1e2085_1
> 
> Test wms:wmsops-getmap-each-style type Mandatory default result
> Passed (s0001/d1e2085_1)
> 
> Assertion: For each of the Styles in the capabilities document,
> when a GetMap request is made with the STYLES parameter set to the
> element of the style, then the response is valid.
> 
> A sequence of more than one item is not allowed as the first
> argument of string() (<Name/>, <Name/>, ...) Result: Failed 
> ======================================
> 
> 
> Bruce Dietrich Pixia Corporation 
> _______________________________________________ CITE-Forum mailing
> list CITE-Forum at lists.opengeospatial.org 
> https://lists.opengeospatial.org/mailman/listinfo/cite-forum 
> _______________________________________________ CITE-Forum mailing
> list CITE-Forum at lists.opengeospatial.org 
> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
> 

- -- 
l a t / l o n  GmbH
Aennchenstrasse 19               53177 Bonn, Germany
phone ++49 +228 18496-0          fax ++49 +228 18496-29
http://www.lat-lon.de            http://www.deegree.org

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iEYEARECAAYFAlOYlUsACgkQq1hDh4aJykIMcgCgsS7LI96Jfa2UwgvS7iN8BQWt
UTsAoL3PJTlWzXYULaZokcPQRLYS7bmh
=iDYm
-----END PGP SIGNATURE-----


More information about the CITE-Forum mailing list