[CITE-Forum] WFS 1.1.0 Content-Type of DescribeFeatureType should be "text/xml"

Peter De Maeyer peter.demaeyer at luciad.com
Fri Dec 5 02:07:39 EST 2014


Luis,

The behavior in revision r21 regarding the Content-Type of 
DescribeFeatureType is still the same as it was in r20.
Did I miss something? Was the decision reverted?

I can imagine that if you change the behavior, all existing 
implementations which depend on the old behavior will suddenly start 
failing...

Kind regards,

Peter

On 11/04/2014 01:41 PM, cite-forum-request at lists.opengeospatial.org wrote:
> Send CITE-Forum mailing list submissions to
> 	cite-forum at lists.opengeospatial.org
>
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://lists.opengeospatial.org/mailman/listinfo/cite-forum
> or, via email, send a message with subject or body 'help' to
> 	cite-forum-request at lists.opengeospatial.org
>
> You can reach the person managing the list at
> 	cite-forum-owner at lists.opengeospatial.org
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of CITE-Forum digest..."
>
>
> Today's Topics:
>
>     1. new revision WMTS r4 at beta testing facility (Luis Bermudez)
>     2. Re: release WMS 1.1.1 r6 and r7 (Luis Bermudez)
>     3. New revision (r10) of WMS 1.3.0 at the OGC Production	Web
>        Testing Facility (Luis Bermudez)
>     4. Re: New revision (r10) of WMS 1.3.0 at the OGC Beta	Web
>        Testing Facility (Luis Bermudez)
>     5. Re: WFS 1.1.0 Content-Type of DescribeFeatureType	should be
>        "text/xml" (Luis Bermudez)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Mon, 3 Nov 2014 17:42:42 -0500
> From: Luis Bermudez <lbermudez at opengeospatial.org>
> To: cite-forum at lists.opengeospatial.org
> Subject: [CITE-Forum] new revision WMTS r4 at beta testing facility
> Message-ID: <5A275FBB-EACE-46A7-86FD-2D4C7401DC2B at opengeospatial.org>
> Content-Type: text/plain; charset=us-ascii
>
> All,
>
> A new revision of Web Map Tile Service (WMTS) 1.0 test (r4) has been released in the OGC Beta Web Testing Facility:
> http://cite.opengeospatial.org/te2
>
> Details can be found at both:
>
> - Release Notes:
>     http://cite.opengeospatial.org/te2/about/wmts/1.0.0/site/
> - Milestone at GitHub:
>     https://github.com/opengeospatial/ets-wmts10/issues?q=milestone%3Ar4+is%3Aclosed
>
> If you have any issues please use the CITE forum or report directly in the issue tracker.
> https://github.com/opengeospatial/ets-wmts10/issues
>
> If you are interesting in being an early implementation or reference implementation, please let me know.
> Early Implementations will have the trademark license fee waived for one year.
>
> Best Regards.
>
> - Luis
>
> ---------------------------------------------------
> Luis Bermudez, Ph.D.
> Director Compliance Program
> Open Geospatial Consortium (OGC)
> The OGC: Making Location Count
>
> Skype: bermudez_luis
> Twitter: @berdez
> Tel: +1 301 760 7323
> http://www.opengeospatial.org/ogc/organization/staff/lbermudez
>
>
>
>
>
>
> ------------------------------
>
> Message: 2
> Date: Tue, 4 Nov 2014 06:34:34 -0500
> From: Luis Bermudez <lbermudez at opengeospatial.org>
> To: cite-forum at lists.opengeospatial.org
> Cc: CITE SC <cite.sc at lists.opengeospatial.org>
> Subject: Re: [CITE-Forum] release WMS 1.1.1 r6 and r7
> Message-ID: <95C95479-569D-4F7B-BB45-FEFD6054E86B at opengeospatial.org>
> Content-Type: text/plain; charset=us-ascii
>
> All
>
> The WMS 1.1.1 test r7, has been moved to the official OGC Testing Facility.
> http://cite.opengeospatial.org/teamengine/
>
> Issues that were closed:
> r7 - https://github.com/opengeospatial/ets-wms11/issues?q=milestone%3Ar7
> Issue #5 - LayerNotDefined - Assertion
>
> r6 - https://github.com/opengeospatial/ets-wms11/issues?q=milestone%3Ar6
> Issue #1 - Broken SRS parameter in some tests
> Issue #3 - Test wms:wmsops-getmap-each-style Exception
>
> If you have any issues please use the CITE forum or report directly in the issue tracker.
> https://github.com/opengeospatial/ets-wms11/issues
>
> Thank you all.
>
> - Luis
>
> ---------------------------------------------------
> Luis Bermudez, Ph.D.
> Director Compliance Program
> Open Geospatial Consortium (OGC)
> The OGC: Making Location Count
>
> Skype: bermudez_luis
> Twitter: @berdez
> Tel: +1 301 760 7323
> http://www.opengeospatial.org/ogc/organization/staff/lbermudez
>
>
>
>
> On Sep 16, 2014, at 1:50 PM, Luis Bermudez <lbermudez at opengeospatial.org> wrote:
>
>> All
>>
>> Revision of WMS 1.1.1 test (r7) were released in the OGC Beta Web Testing Facility early in June
>> http://cite.opengeospatial.org/te2
>>
>> Will give one more month to check if there are any issues with these two releases. Please note that the revision at the production web site is r5.
>>
>> Details of releases r6 and r7  can be found at both:
>>
>> - Milestone at GitHub:
>>    https://github.com/opengeospatial/ets-wms11/issues?q=milestone%3Ar7
>>    https://github.com/opengeospatial/ets-wms11/issues?q=milestone%3Ar7
>>
>> - Release Notes:
>>    http://cite.opengeospatial.org/te2/about/wms/1.1.1/web/relnotes.txt
>>
>> r7 (2014-06-24)
>> ------------------
>> - added HTTPParser to wmsops-getmap-params-layers-6 test
>>
>> r6 (2014-06-20)
>> ---------------
>> - Fixed CITE-943: (GetFeatureInfo) tests fail but the response seems valid.
>> - Fixed CITE-828: In functions:layer-info, look for preferred SRS ("EPSG:4326") if given.
>>
>>
>> If you have any issues please use the CITE forum or report directly in the issue tracker.
>> https://github.com/opengeospatial/ets-wms11/issues
>>
>> If everything is ok, will move this revision r7 (which contains r6 fixes as well) to the OGC operational web site in the last week of October.
>>
>> Thank you very much!
>>
>>
>> - Luis
>>
>> ---------------------------------------------------
>> Luis Bermudez, Ph.D.
>> Director Compliance Program
>> Open Geospatial Consortium (OGC)
>> The OGC: Making Location Count
>>
>> Skype: bermudez_luis
>> Twitter: @berdez
>> Tel: +1 301 760 7323
>> http://www.opengeospatial.org/ogc/organization/staff/lbermudez
>>
>>
>>
>>
>
>
> ------------------------------
>
> Message: 3
> Date: Tue, 4 Nov 2014 07:29:53 -0500
> From: Luis Bermudez <lbermudez at opengeospatial.org>
> To: cite-forum at lists.opengeospatial.org
> Cc: CITE SC <cite.sc at lists.opengeospatial.org>
> Subject: [CITE-Forum] New revision (r10) of WMS 1.3.0 at the OGC
> 	Production	Web Testing Facility
> Message-ID: <C605AEAF-1B81-4BB2-B90A-8B218C0CA230 at opengeospatial.org>
> Content-Type: text/plain; charset=us-ascii
>
> All
>
> The WMS 1.3.0 r10 has been moved to the official OGC Testing Facility
> http://cite.opengeospatial.org/teamengine/
>
> Release notes are available here:
> http://cite.opengeospatial.org/teamengine/about/wms/1.3.0/site/relnotes.html
>
> r9 - https://github.com/opengeospatial/ets-wms13/issues?q=milestone%3Ar9
> Issue #6 - Empty CRS code in CRS-parameter
> Issue #4 - XPath error in getfeatureinfo:query_layers-not-queryable
>
> r10 - https://github.com/opengeospatial/ets-wms13/issues?q=milestone%3Ar10
> Issue #7 - image/png8 and image/png24 are not valid iana media types
>
> If you have any issues please use the CITE forum or report directly in the issue tracker.
> https://github.com/opengeospatial/ets-wms13/issues
>
> Thank you!
>
> - Luis
>
> ---------------------------------------------------
> Luis Bermudez, Ph.D.
> Director Compliance Program
> Open Geospatial Consortium (OGC)
> The OGC: Making Location Count
>
> Skype: bermudez_luis
> Twitter: @berdez
> Tel: +1 301 760 7323
> http://www.opengeospatial.org/ogc/organization/staff/lbermudez
>
>
>
> On Oct 1, 2014, at 3:29 PM, Luis Bermudez <lbermudez at opengeospatial.org> wrote:
>
>> All,
>>
>> A new revision (r10) of WMS 1.3.0 test suite has been released in the OGC Beta Web Testing Facility [1].
>> Details of the release are available at the release notes [2]. If you encounter any issue please use the CITE forum [3] or report directly in the issue tracker [4].
>>
>> If we do not hear of any issues, we will move this revision to the OGC operational web site [5] at the end of the month.
>>
>> Thank you much!
>>
>> [1] OGC Beta Testing Facility: http://cite.opengeospatial.org/te2
>> [2] Release Notes: http://cite.opengeospatial.org/te2/about/wms/1.3.0/site/relnotes.html
>> [3] CITE Forum: http://cite.opengeospatial.org/forum
>> [4] Issue tracker: https://github.com/opengeospatial/ets-wms13/issues
>> [5] OGC Operational Testing Facility: http://cite.opengeospatial.org/teamengine/
>>
>> Best Regards.
>>
>> - Luis
>>
>> ---------------------------------------------------
>> Luis Bermudez, Ph.D.
>> Director Compliance Program
>> Open Geospatial Consortium (OGC)
>> The OGC: Making Location Count
>>
>> Skype: bermudez_luis
>> Twitter: @berdez
>> Tel: +1 301 760 7323
>> http://www.opengeospatial.org/ogc/organization/staff/lbermudez
>>
>>
>>
>>
>
>
> ------------------------------
>
> Message: 4
> Date: Tue, 4 Nov 2014 07:33:03 -0500
> From: Luis Bermudez <lbermudez at opengeospatial.org>
> To: Mats Olsson <Mats.Olsson at carmenta.com>
> Cc: "cite-forum at lists.opengeospatial.org"
> 	<cite-forum at lists.opengeospatial.org>
> Subject: Re: [CITE-Forum] New revision (r10) of WMS 1.3.0 at the OGC
> 	Beta	Web	Testing Facility
> Message-ID: <F1438E73-6229-40C6-9C96-21E96A8F1939 at opengeospatial.org>
> Content-Type: text/plain; charset=us-ascii
>
> Hi Mats
>
> Thank you for reporting. The fix will be available in r11
> https://github.com/opengeospatial/ets-wms13/issues?q=milestone%3Ar11+is%3Aclosed
>
> - Luis
>
> ---------------------------------------------------
> Luis Bermudez, Ph.D.
> Director Compliance Program
> Open Geospatial Consortium (OGC)
> The OGC: Making Location Count
>
> Skype: bermudez_luis
> Twitter: @berdez
> Tel: +1 301 760 7323
> http://www.opengeospatial.org/ogc/organization/staff/lbermudez
>
>
>
>
> On Oct 2, 2014, at 10:00 AM, Mats Olsson <Mats.Olsson at carmenta.com> wrote:
>
>> Hello!
>>
>> I ran the WMS 1.3.0 tests on the beta test site and the basic, queryable and recommendation tests all works as intended for me.
>>
>> However I noticed an issue with the optional test main:time (not sure if this also affects the elevation tests). If the values for nearestValue and multipleValues is set to "true" the test throws an exception:
>>
>> Error in call to extension function {public synchronized void com.occamlab.te.TECore.callTest(net.sf.saxon.expr.XPathContext,java.lang.String,java.lang.String,net.sf.saxon.om.NodeInfo,java.lang.String) throws java.lang.Exception}: Exception in extension function java.lang.RuntimeException: net.sf.saxon.s9api.SaxonApiException: Cannot convert string "true" to a double
>>
>> Setting them to "1" instead works, but as the schema defines these values as booleans shouldn't both variants be ok?
>>
>> This is not a new issue as it happens on the production site as well, but I thought I mention it anyway.
>>
>> Best regards,
>> Mats Olsson
>>
>> -----Original Message-----
>> From: CITE-Forum [mailto:cite-forum-bounces at lists.opengeospatial.org] On Behalf Of Luis Bermudez
>> Sent: den 1 oktober 2014 21:30
>> To: cite-forum at lists.opengeospatial.org
>> Subject: [CITE-Forum] New revision (r10) of WMS 1.3.0 at the OGC Beta Web Testing Facility
>>
>> All,
>>
>> A new revision (r10) of WMS 1.3.0 test suite has been released in the OGC Beta Web Testing Facility [1].
>> Details of the release are available at the release notes [2]. If you encounter any issue please use the CITE forum [3] or report directly in the issue tracker [4].
>>
>> If we do not hear of any issues, we will move this revision to the OGC operational web site [5] at the end of the month.
>>
>> Thank you much!
>>
>> [1] OGC Beta Testing Facility: http://cite.opengeospatial.org/te2
>> [2] Release Notes: http://cite.opengeospatial.org/te2/about/wms/1.3.0/site/relnotes.html
>> [3] CITE Forum: http://cite.opengeospatial.org/forum
>> [4] Issue tracker: https://github.com/opengeospatial/ets-wms13/issues
>> [5] OGC Operational Testing Facility: http://cite.opengeospatial.org/teamengine/
>>
>> Best Regards.
>>
>> - Luis
>>
>> ---------------------------------------------------
>> Luis Bermudez, Ph.D.
>> Director Compliance Program
>> Open Geospatial Consortium (OGC)
>> The OGC: Making Location Count
>>
>> Skype: bermudez_luis
>> Twitter: @berdez
>> Tel: +1 301 760 7323
>> http://www.opengeospatial.org/ogc/organization/staff/lbermudez
>>
>>
>>
>>
>> _______________________________________________
>> CITE-Forum mailing list
>> CITE-Forum at lists.opengeospatial.org
>> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
>> _______________________________________________
>> CITE-Forum mailing list
>> CITE-Forum at lists.opengeospatial.org
>> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
>
>
> ------------------------------
>
> Message: 5
> Date: Tue, 4 Nov 2014 07:41:28 -0500
> From: Luis Bermudez <lbermudez at opengeospatial.org>
> To: peter.demaeyer at luciad.com
> Cc: cite-forum at lists.opengeospatial.org
> Subject: Re: [CITE-Forum] WFS 1.1.0 Content-Type of
> 	DescribeFeatureType	should be "text/xml"
> Message-ID: <DA2D70AA-CF04-4D91-97C7-0591F3558728 at opengeospatial.org>
> Content-Type: text/plain; charset="us-ascii"
>
> Hi Peter
>
> Sebastian fixed this issue last month. Fix will be available in revision r21 later in the month.
>
> - Luis
>
> ---------------------------------------------------
> Luis Bermudez, Ph.D.
> Director Compliance Program
> Open Geospatial Consortium (OGC)
> The OGC: Making Location Count
>
> Skype: bermudez_luis
> Twitter: @berdez
> Tel: +1 301 760 7323
> http://www.opengeospatial.org/ogc/organization/staff/lbermudez
>
>
>
>
> On Oct 9, 2014, at 4:30 AM, Sebastian Goerke <goerke at lat-lon.de> wrote:
>
>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA1
>>
>> Hi Peter,
>>
>> yes you are right, we are going to investigate and fix.
>>
>> Best regards
>>
>> Sebastian
>>
>> Am 07.10.2014 um 13:59 schrieb Peter De Maeyer:
>>> I'm a bit puzzled by the assertion of the test
>>> wfs:DescribeFeatureType-output-format-default (WFS 1.1.0).
>>>
>>> It expects the Content-Type (MIME type) of the DescribeFeatureType
>>> response to be "text/xml; subtype=gml/3.1.1". I believe this to be
>>> incorrect. Since the response is an XSD, the correct Content-Type
>>> should be "text/xml".
>>>
>>> I guess the confusion comes from the outputFormat parameter of
>>> DescribeFeatureType. The default outputFormat is "text/xml;
>>> subtype=gml/3.1.1", which is the MIME type of the features
>>> themselves, but not the MIME type of the /description/ of the
>>> feature type.
>>>
>>> Right?
>>>
>>> Thanks,
>>>
>>> Peter
>>>
>>>
>>> _______________________________________________ CITE-Forum mailing
>>> list CITE-Forum at lists.opengeospatial.org
>>> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
>>>
>> - -- 
>> l a t / l o n  GmbH
>> Aennchenstrasse 19               53177 Bonn, Germany
>> phone ++49 +228 18496-0          fax ++49 +228 18496-29
>> http://www.lat-lon.de            http://www.deegree.org
>>
>> -----BEGIN PGP SIGNATURE-----
>> Version: GnuPG v1
>>
>> iEYEARECAAYFAlQ2R5IACgkQq1hDh4aJykJmgwCfRJuX8N7OuuF33YBfwgHPrOEK
>> Tu8An3Dz6DFiIuxwfzM2lC4dj85X7CPq
>> =KTsT
>> -----END PGP SIGNATURE-----
>> _______________________________________________
>> CITE-Forum mailing list
>> CITE-Forum at lists.opengeospatial.org
>> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20141104/ed803930/attachment.html>
>
> ------------------------------
>
> Subject: Digest Footer
>
> _______________________________________________
> CITE-Forum mailing list
> CITE-Forum at lists.opengeospatial.org
> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
>
>
> ------------------------------
>
> End of CITE-Forum Digest, Vol 88, Issue 1
> *****************************************



More information about the CITE-Forum mailing list