[CITE-Forum] WMS 1.1.1 DTD link

Richard Martell rmartell at galdosinc.com
Fri Apr 25 16:31:13 EDT 2014


Christine,

The correct schema reference is:
<http://schemas.opengis.net/wms/1.1.1/capabilities_1_1_1.dtd>

This DTD includes all Extent attributes documented in clause C.3 (some were missing in A.1).

--
Richard



From: CITE-Forum [mailto:cite-forum-bounces at lists.opengeospatial.org] On Behalf Of Christine Bao
Sent: Friday, 25 April, 2014 01:31
To: cite-forum at lists.opengeospatial.org
Cc: Klain Qin
Subject: Re: [CITE-Forum] WMS 1.1.1 DTD link

Hi OGC experts,

I am running test for WMS 1.1.1, GetCapabilities link http://54.215.6.158:8088/mapserver2015/mapagent/mapagent.fcgi?REQUEST=GETCAPABILITIES&SERVICE=WMS&VERSION=1.1.1<http://54.215.6.158:8088/mapserver2015/mapagent/mapagent.fcgi?REQUEST=GETCAPABILITIES&SERVICE=WMS&VERSION=1.1.1&FORMAT=text%2Fxml>

It fails for one case s0008/d1e1033_1 due to DTD link. My original link is below:
  <!DOCTYPE WMT_MS_Capabilities SYSTEM
"http://schemas.opengis.net/wms/1.1.1/WMS_MS_Capabilities.dtd"
  [
   <!ELEMENT VendorSpecificCapabilities EMPTY>
  ]>

But it reports "*** does not match the dtd expected from the specification".

In your specification https://www.google.com.hk/url?sa=t&rct=j&q=&esrc=s&source=web&cd=3&ved=0CEAQFjAC&url=http%3A%2F%2Fportal.opengeospatial.org%2Ffiles%2F%3Fartifact_id%3D1081%26version%3D1%26format%3Dpdf&ei=7BVaU9HyO-Lf8AHpwYGQDQ&usg=AFQjCNEUPdTm9-g2O9-tUbpGMeoWIImpRA&bvm=bv.65397613,d.aWw the sample uses this below:
  <!DOCTYPE WMT_MS_Capabilities SYSTEM
"http://www.digitalearth.gov/wmt/xml/capabilities_1_1_1.dtd"
  [
   <!ELEMENT VendorSpecificCapabilities EMPTY>
  ]>

However http://www.digitalearth.gov/wmt/xml/capabilities_1_1_1.dtd is not accessible.

I even copy A.1 DTD into a file and host in my server http://54.215.6.158:8088/mapserver2015/mapagent/WMS111.dtd however the test case still says it does not match the dtd expected.

Would you please check the test case, or is there a valid public dtd link?

Thanks & regards,
Christine

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20140425/0dc39399/attachment.html>


More information about the CITE-Forum mailing list