[CITE-Forum] New OGC TEAM Engine production release

Richard Martell rmartell at galdosinc.com
Wed Apr 23 17:39:33 EDT 2014


Mats,

Did you try running the WFS2 suite on the 'beta' service at <http://cite.opengeospatial.org/te2/>?
If so, did you see the same exception occur there?


--
Richard


-----Original Message-----
From: CITE-Forum [mailto:cite-forum-bounces at lists.opengeospatial.org] On Behalf Of Mats Olsson
Sent: Wednesday, 23 April, 2014 07:44
To: cite-forum at lists.opengeospatial.org
Subject: Re: [CITE-Forum] New OGC TEAM Engine production release

Hello,

Seems to be lots of improvements here, all issues I have seen in the older versions of the WMS 1.1.1 & 1.3.0 and WFS 1.1.0 tests are gone now.

However there are a couple of things I cannot get to work with the new release:

WFS 2.0 tests now crash after a while with a NullPointerException. I ran the old tests against the same service just before the update and it worked then.
The complete error message is:
Error in call to extension function {public java.lang.Object com.occamlab.te.TECore.callFunction(net.sf.saxon.expr.XPathContext,java.lang.String,java.lang.String,net.sf.saxon.om.NodeInfo) throws java.lang.Exception}: Exception in extension function net.sf.saxon.s9api.SaxonApiException: Error in call to extension function {public javax.xml.transform.Source org.opengis.cite.iso19142.TestNGController.doTestRun(org.w3c.dom.Document) throws java.lang.Exception}: Exception in extension function java.lang.NullPointerException

WCS 1.1.1 tests still has some sort of XPath problem that breaks the GetCoverage-tests (probably the same problem as described in issue 843) when you have more than one BoundingBox in your DescribeCoverage response.

A more general TEAM Engine issue is that almost every time the tests are updated the old sessions stored in my profile seems to break. They are still there but when you select them in the list they either return an internal error with a java exception (different for different test sessions), or you can see the previous results but the line Test Suite: error: suitEntry is null appears above the results and no buttons appear. This makes broken test sessions that cannot be removed accumulate in the profile.

Best regards,
Mats Olsson

-----Original Message-----
From: CITE-Forum [mailto:cite-forum-bounces+mats.olsson=carmenta.com at lists.opengeospatial.org] On Behalf Of Luis Bermudez
Sent: den 23 april 2014 14:30
To: cite-forum at lists.opengeospatial.org
Cc: CITE Development; CITE SC
Subject: [CITE-Forum] New OGC TEAM Engine production release

Dear CITE SC and CITE Forum Members,

I am very pleased to announce a new release of the TEAM Engine production testing site: http://cite.opengeospatial.org/teamengine/

As discussed in the last TC, it was planned to make a new release of the minor changes in the current adopted test suites. No new test suite is part of this release.

Details of the release are in the CITE wiki http://cite.opengeospatial.org/r20140423p

I very much appreciate all your participation and important involvement in all the issues discussed, in particular the CITE team [1] and the maintainers of the reference implementations [2]

[1] http://cite.opengeospatial.org/team
[2] http://cite.opengeospatial.org/reference

Thank you all !

- Luis

---------------------------------------------------
Luis Bermudez, Ph.D.
Director Compliance Program
Open Geospatial Consortium (OGC)
The OGC: Making Location Count

Skype: bermudez_luis
Twitter: @berdez
Tel: +1 301 760 7323
http://www.opengeospatial.org/ogc/organization/staff/lbermudez




_______________________________________________
CITE-Forum mailing list
CITE-Forum at lists.opengeospatial.org
https://lists.opengeospatial.org/mailman/listinfo/cite-forum
_______________________________________________
CITE-Forum mailing list
CITE-Forum at lists.opengeospatial.org
https://lists.opengeospatial.org/mailman/listinfo/cite-forum


More information about the CITE-Forum mailing list