[CITE-Forum] Beta WMTS Tests do not work correctly

Richard Martell rmartell at galdosinc.com
Mon Mar 4 18:06:20 EST 2013


Sebastian,


The examples appearing in the WMTS spec (OGC 07-057r7) show encoding constraints 
at the method level:

e.g.
* 7.1.1.3: ServiceMetadata document example 
* Annex D.2 (informative): ServiceMetadata response example


Can you add a comment to the issue identifying the requirement statement(s) 
in the text?

<https://portal.opengeospatial.org/?m=projects&a=view&project_id=85&tab=5&act=details&issue_id=777>


There is a rather confusing paragraph in cl. 7.1.1.1.1 (p.15), but that 
stipulates that constraints appear either (a) in a request method, or 
(b) in ows:OperationsMetadata/ows:Constraint.


--
Richard

> -----Original Message-----
> From: 
> cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial
> .org 
> [mailto:cite-forum-bounces+rmartell=galdosinc.com at lists.openge
> ospatial.org] On Behalf Of Sebastian Goerke
> Sent: Wednesday, 27 February, 2013 01:04
> To: cite-forum at lists.opengeospatial.org
> Subject: Re: [CITE-Forum] Beta WMTS Tests do not work correctly
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hi again,
> 
> I think I've found it.
> 
> The WMTS test suite excepts the following path for the encodings:
> 
> $wmts.capabilities.doc/ows:OperationsMetadata/ows:Operation[@n
> ame='GetCapabilities']//ows:Get/ows:Constraint[@name='GetEncod
> ing']/ows:AllowedValues/ows:Value
> = 'KVP'
> 
> But actually it is, following the specification:
> 
> <ows:Operation name="GetCapabilities">
>       <ows:DCP>
>         <ows:HTTP>
>           <ows:Get
> xlink:href="http://ows9.lat-lon.de/deegree-webservices-3.2-pre
> 15/services/wmts?"/>
>         </ows:HTTP>
>       </ows:DCP>
>       <ows:Constraint name="GetEncoding">
>         <ows:AllowedValues>
>           <ows:Value>KVP</ows:Value>
>         </ows:AllowedValues>
>       </ows:Constraint>
>     </ows:Operation>
> 
> So, for me it seems, the test suite is wrong here.
> 
> Who is responsible for the WMTS test suite currently? Seems to be
> under development (Got this from SVN messages)
> 
> Regards
> 
> Sebastian
> 
> Am 27.02.2013 09:55, schrieb Sebastian Goerke:
> > Hi all,
> > 
> > it seems that the WMTS tests from the Team Engine Beta release do
> > not work correctly.
> > 
> > I tested the following service:
> > 
> > 
> http://ows9.lat-lon.de/deegree-webservices-3.2-pre15/services/
> wmts?service=WMTS&request=GetCapabilities&version=1.0.0
> >
> >  for the GET KVP Encoding and got following output:
> > 
> > Test wmts:server.profile.kvp.get.main type Mandatory default
> > result Passed (s0009/server.profile.kvp.get)
> > 
> > Assertion: The server satisfies all Mandatory and 
> > MandatoryIfImplemented requiresments for the KVP GET binding.  It
> > must support both GetCapabilities and GetTile operations for KVP
> > GET binding for any further tests to be performed.
> > 
> > Context: Label: Value: wmts:server.profile.kvp.get
> > 
> > Message d2874e486_1: KVP GET
> > 
> > Message d2874e547_1: Checking prerequisites...
> > 
> > Message d35555e508_1: Server does not support KVP GET
> > GetCapabilities and GetTile ... failed prerequisite check.  No
> > other test will be executed.
> > 
> > Message d2874e570_1: check.prerequisites.elapsed [105]
> > milliseconds
> > 
> > Message d2874e663_1: [SKIPPED] GET binding not supported.
> > 
> > Result: Skipped
> > 
> > 
> > But the service definitely does support GET KVP for
> > GetCapabilities and GetTile operations as also stated within the
> > capabilities document.
> > 
> > Regards
> > 
> > Sebastian
> > 
> > _______________________________________________ CITE-Forum mailing
> > list CITE-Forum at lists.opengeospatial.org 
> > https://lists.opengeospatial.org/mailman/listinfo/cite-forum
> > 
> 
> - -- 
> l a t / l o n  GmbH
> Aennchenstrasse 19               53177 Bonn, Germany
> phone ++49 +228 18496-0          fax ++49 +228 18496-29
> http://www.lat-lon.de            http://www.deegree.org
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> Comment: Using GnuPG with undefined - http://www.enigmail.net/
> 
> iEYEARECAAYFAlEtzBkACgkQq1hDh4aJykK4ZQCfSDyt3mV2z7rBfKR/R62CoBnF
> DG8AniYO2jQ0J87N9VKsHHcjPf3BJXo8
> =IdnT
> -----END PGP SIGNATURE-----
> _______________________________________________
> CITE-Forum mailing list
> CITE-Forum at lists.opengeospatial.org
> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
> 


More information about the CITE-Forum mailing list