[CITE-Forum] Help with WMTS 1.0.0 testing

ULAS AYDINER ulas.aydiner at netcad.com.tr
Tue Jun 11 09:11:03 EDT 2013


Neil, you have the sharpest of eyes!

Thank you so much.

Ulaş

From: Neil Tippett [mailto:neil.tippett at envitia.com]
Sent: Tuesday, June 11, 2013 4:11 PM
To: ULAS AYDINER; cite-forum at lists.opengeospatial.org
Subject: RE: [CITE-Forum] Help with WMTS 1.0.0 testing

Hello again Ulaş,

The error generated does not relate to the snippet from your Capabilities document that you've list, it instead relates to the following block:

<ows:Operation name="GetTile">
      <ows:DCP>
        <ows:HTTP>
          <ows:Get xlink:href="http://91.93.170.250:88/netgissvn/wmts.ashx?">
            <ows:Constraint name="GetEncoding">
              <ows:AllowedValues>
                <ows:Value>KVP</ows:Value>
              </ows:AllowedValues>
            </ows:Constraint>
          </ows:Get>
        </ows:HTTP>
      </ows:DCP>
      <ows:Parameter>
        <ows:AllowedValues />
      </ows:Parameter>
    </ows:Operation>

In this block you've got an ows:Parameter element without the mandatory name attribute and an ows:AllowedValue element without any of the required children.

Hope that helps,

Regards

Neil

Envitia
See the world as it really is

Neil Tippett
Software Engineer
* Tel:      +44 1403 273 173
7 Fax:     +44 1403 273 123
* Email:  neil.tippett at envitia.com<mailto:neil.tippett at envitia.com>
* Web:   www.envitia.com<http://www.envitia.com>
ISO 9001:2008 Quality Management System Accreditation

[Logo for SIGNATURE]
__________________________________________________________________________________________________
This email is intended for the use of the addressee(s) only. The content and any attachments may be privileged and/or
contain confidential information and copyright material. If you are not the addressee you may not use, copy or disclose
the information in it. If you receive this email by mistake, please advise the sender by using the reply facility in your email
software or the contact information above, before deleting it and destroying any hard copies.
We accept no responsibility or liability for content in this email that is personal or otherwise unconnected with our business.
Although this email and attachments have been swept for viruses, we do not accept liability for any loss arising from its use.

Envitia Ltd
Registered No: 2348404 England
North Heath Lane, Horsham, West Sussex RH12 5UX
__________________________________________________________________________________________________


From: cite-forum-bounces+neil.tippett=envitia.com at lists.opengeospatial.org<mailto:cite-forum-bounces+neil.tippett=envitia.com at lists.opengeospatial.org> [mailto:cite-forum-bounces+neil.tippett=envitia.com at lists.opengeospatial.org] On Behalf Of ULAS AYDINER
Sent: 11 June 2013 14:00
To: cite-forum at lists.opengeospatial.org<mailto:cite-forum at lists.opengeospatial.org>
Subject: [CITE-Forum] Help with WMTS 1.0.0 testing

Hello everyone,

I am having trouble understanding the issue with the WMTS 1.0.0 test on the new team engine. My capabilities document is not validated with the below message:

Messages from parser parsers:XMLValidatingParser:
        Validation error:
  cvc-complex-type.4: Attribute 'name' must appear on element 'ows:Parameter'.
Validation error:
  cvc-complex-type.2.4.b: The content of element 'ows:AllowedValues' is not complete. One of '{"http://www.opengis.net/ows/1.1":Value, "http://www.opengis.net/ows/1.1":Range}' is expected.
2 validation errors detected.

But the relevant document section is given below and I believe to have provided all the necessary elements, attributes etc.

<ows:Operation name="GetCapabilities">
<ows:DCP>
<ows:HTTP>
<ows:Get xlink:href="http://91.93.170.250:88/netgissvn/wmts.ashx?">
<ows:Constraint name="GetEncoding">
<ows:AllowedValues>
<ows:Value>KVP</ows:Value>
</ows:AllowedValues>
</ows:Constraint>
</ows:Get>
</ows:HTTP>
</ows:DCP>
<ows:Parameter name="AcceptFormats">
<ows:AllowedValues>
<ows:Value>application/xml</ows:Value>
</ows:AllowedValues>
</ows:Parameter>
</ows:Operation>

And below is the URL to the capabilities document:

http://91.93.170.250:88/netgissvn/wmts.ashx?service=WMTS&request=GetCapabilities

What am I missing here? Please help.

Thank you all in advance.

Ulaş


ULAS AYDINER
PROJE YÖNETİCİSİ
ulas.aydiner at netcad.com.tr<mailto:ulas.aydiner at netcad.com.tr>



Cyber Park B Blok No:409
06800, Bilkent / Ankara
Tel. :(0312) 265 0510 - 223
Faks: (312) 265 0520


     [line.jpg]


[NETCAD]<http://www.netcad.com.tr/>
ULUSAL CAD ve GIS
ÇÖZÜMLERİ A.Ş.
www.netcad.com.tr<http://www.netcad.com.tr>












ULAS AYDINER
PROJE YÖNETİCİSİ
ulas.aydiner at netcad.com.tr



Cyber Park B Blok No:409
06800, Bilkent / Ankara
Tel. :(0312) 265 0510 - 223
Faks: (312) 265 0520


[NETCAD] <http://www.netcad.com.tr/>
ULUSAL CAD ve GIS
ÇÖZÜMLERİ A.Ş.
www.netcad.com.tr<http://www.netcad.com.tr>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20130611/eada4690/attachment-0001.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.jpg
Type: image/jpeg
Size: 1503 bytes
Desc: image001.jpg
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20130611/eada4690/attachment-0001.jpg>


More information about the CITE-Forum mailing list