[CITE-Forum] WFS 1.0 setup instructions incomplete

Luis Bermudez lbermudez at opengeospatial.org
Tue Dec 10 07:09:59 EST 2013


Hi Andrea

I'm running locally via command line. I have all the jars created in ets-resources under TE_BASE/resources/lib.

Maybe you also need: 
- schema-utils-1.3.jar

- Luis

---------------------------------------------------
Luis Bermudez, Ph.D.
Director Compliance Program
Open Geospatial Consortium (OGC)
The OGC: Making Location Count

Skype: bermudez_luis
Twitter: @berdez
Tel: +1 301 760 7323
http://www.opengeospatial.org/ogc/organization/staff/lbermudez




On Dec 10, 2013, at 6:21 AM, Andrea Aime <andrea.aime at geo-solutions.it> wrote:

> On Mon, Dec 9, 2013 at 7:49 PM, Richard Martell <rmartell at galdosinc.com> wrote:
> Andrea,
> 
>  
> 
>  
> 
> Hm. I’m not able to reproduce the issue. It turns out the resources element is not required in the teamengine config file because those schemas are included in cite1-utils-1.1.0.jar.
> 
> 
> Right. I've verified that file is in WEB-INF/lib of the teamengine webapp and indeed it contains those files.
> Yet, the tests are not working.
>  
> 
>  
> 
> I ran the WFS 1.0 test suite against this implementation and didn’t see any exceptions in the log files. In fact all tests passed:
> 
>  
> 
> <http://cite.lat-lon.de/deegree-webservices-3.3.6/services/wfs100?service=WFS&version=1.0.0&request=GetCapabilities>
> 
>  
> 
> Did you build ets-resources from the trunk? It should include the following required libs (plus those needed for other test suites) that
> 
> must then be placed in teamengine/WEB-INF/lib:
> 
>  
> 
> - cite1-utils-1.1.0.jar (schemas are packaged in here)
> 
> - gml2-validator-1.1.jar
> 
> - saxpath-1.0-FCS.jar
> 
> - jaxen-1.0-FCS.jar
> 
> 
> Yes, I have verified I have all of those.
>  
> 
>  
> 
> Alternatively, you can try building teamengine and activating the ogc.cite profile (-P ogc.cite); doing this will automatically add the supporting
> 
> libs to the WAR file.
> 
> 
> I'm running the code build off svn://svn.code.sf.net/p/teamengine/code/tags/4.0.3, which is the same
> version run by the official site.
> I see it has that profile, just wondering if it's maybe too old?
> 
> Cheers
> Andrea
> 
> -- 
> ==
> Our support, Your Success! Visit http://opensdi.geo-solutions.it for more information.
> ==
> 
> Ing. Andrea Aime 
> @geowolf
> Technical Lead
> 
> GeoSolutions S.A.S.
> Via Poggio alle Viti 1187
> 55054  Massarosa (LU)
> Italy
> phone: +39 0584 962313
> fax: +39 0584 1660272
> mob: +39  339 8844549
> 
> http://www.geo-solutions.it
> http://twitter.com/geosolutions_it
> 
> -------------------------------------------------------
> _______________________________________________
> CITE-Forum mailing list
> CITE-Forum at lists.opengeospatial.org
> https://lists.opengeospatial.org/mailman/listinfo/cite-forum

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20131210/e2d9a29f/attachment.html>


More information about the CITE-Forum mailing list