[CITE-Forum] Axis order change breaks standard compatibility in WFS 1.1?

Andrea Aime andrea.aime at geo-solutions.it
Sat Dec 7 12:23:49 EST 2013


Hi,
I was looking into a fix that is causing a failure and I'm not really
following the
reasoning behind the change:

https://portal.opengeospatial.org/services/srv_public_issues.php?call=viewIssue&issue_id=898

Basically, it seems the reporter claims that if the SRS for the bbox in a
request is not specified,
then the default SRS should be used. No argument there, yet, both Deegree
and GeoServer capabilities responses state:


<DefaultSRS>urn:ogc:def:crs:EPSG:6.11.2:4326</DefaultSRS>
<DefaultSRS>urn:ogc:def:crs:EPSG::4326</DefaultSRS>

Which are lat/lon oriented. Yet, the reporter states the order of the axis
in the GET
request should be lon/lat oriented because that's the order
of urn:ogc:def:crs:OGC:1.3:CRS84"
And that's where I've completely lost the discussion... where in the world
is that CRS used
in the capabilities documents? The default srs is explicitly declared and
it's not CRS84.

Mind, if servers start implementing this "new" order most of the open
source clients out there will
start failing.

Cheers
Andrea

-- 
==
Our support, Your Success! Visit http://opensdi.geo-solutions.it for more
information.
==

Ing. Andrea Aime
@geowolf
Technical Lead

GeoSolutions S.A.S.
Via Poggio alle Viti 1187
55054  Massarosa (LU)
Italy
phone: +39 0584 962313
fax: +39 0584 1660272
mob: +39  339 8844549

http://www.geo-solutions.it
http://twitter.com/geosolutions_it

-------------------------------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20131207/5f8bad0c/attachment.html>


More information about the CITE-Forum mailing list