[CITE-Forum] Testing Locally

BARIS KAZAR baris.kazar at oracle.com
Fri Apr 26 18:49:06 EDT 2013


Hi Richard,-
  I sent to your email only the initial wfs:FeatureCollection response we received.
The following belongs to the filter part of the secondary GetFeature request.
<ogc:Filter><ogc:GmlObjectId gml:id="f001 f002 f003 f008 f015"/></ogc:Filter>
I am not sure why it lists all ID's.
I think we should expect all the featureType instances in the initial response, right?

Best regards
baris

On 4/26/2013 6:12 PM, BARIS KAZAR wrote:
> Hi Richard,-
>   I am not sure when #2 was done but Andreas told as i indicated in the URL
> that Andreas fixed the trunk at that time.
> I did not file an issue in the Issue Tracker for this, but we can definitely file one.
> Best regards
> baris
>
> On 4/26/2013 5:05 PM, Richard Martell wrote:
>> Baris,
>>
>>
>> Regarding #2 below, you'll see from the svn log in the OGC repository that
>> there were no updates to GetFeature-POST-spatialops.xml in March 2011.
>>
>>
>>> svn log GetFeature-POST-spatialops.xml
>> ------------------------------------------------------------------------
>> r5317 | rmartell | 2013-02-09 07:15:30 -0800 (Sat, 09 Feb 2013) | 1 line
>>
>> Fixed Schematron schema classpath references.
>> ------------------------------------------------------------------------
>> r4998 | sgoerke | 2012-11-20 03:01:05 -0800 (Tue, 20 Nov 2012) | 4 lines
>>
>> update test data to correct EPSG:4326 urn encoded writing.
>> fix issue 669 regarding wrong urn encoded writing of EPSG:32629 and EPSG:32631
>>
>>
>> ------------------------------------------------------------------------
>> r3728 | aschmitz | 2011-01-14 02:29:02 -0800 (Fri, 14 Jan 2011) | 2 lines
>>
>> removed test 204.4, see issue #572
>>
>> ------------------------------------------------------------------------
>> r3450 | aschmitz | 2010-08-03 00:43:10 -0700 (Tue, 03 Aug 2010) | 2 lines
>>
>> fix for issue #551
>>
>>
>>
>> There don't appear to be any relevant bug reports for WFS 1.1 in the
>> CITE issue tracker at <http://cite.opengeospatial.org/issues>.
>>
>> Perhaps you could add one if I overlooked it.
>>
>>
>> -- 
>> Richard
>>
>>
>>> -----Original Message-----
>>> From:
>>> cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial
>>> .org
>>> [mailto:cite-forum-bounces+rmartell=galdosinc.com at lists.openge
>>> ospatial.org] On Behalf Of BARIS KAZAR
>>> Sent: Friday, 26 April, 2013 08:27
>>> To: cite-forum at lists.opengeospatial.org
>>> Subject: Re: [CITE-Forum] Testing Locally
>>>
>>> Hi,-
>>> May i ask the following problems with TeamEngine 4.0 tests?
>>>
>>> 1)
>>> I think any exception for the following tests is ok, right?
>>> Why are the tests forcing to have InvalidParameterValue exception?
>>> I think the CTL codes are the same but previously TeamEngine
>>> did not enforce this.
>>> wfs-1.1.0-Basic-GetFeature-tc101.3
>>> wfs-1.1.0-Basic-GetFeature-tc202.1
>>> wfs-1.1.0-Basic-GetFeature-tc203.3
>>>
>>> 2)
>>> Why is the whitespace at the end of the following
>>> wfs-1.1.0-Basic-GetFeature-tc209.1.test not ignored?
>>> Please check out
>>> http://lists.opengeospatial.org/pipermail/cite-forum/2011-Marc
>>> h/000463.html
>>> It seems this fix is not in TeamEngine 4.0 distribution
>>> <message id="d207e12133_1"><![CDATA[FAILURE: Expected gml:pos
>>> of "34.94 -10.52" (found: 34.94 -10.52 ).]]></message>
>>>
>>> 3)
>>> We still have the following issue: multiple values in gml:id
>>> attribute of ogc:GmlObjectId  element in
>>> wfs-1.1.0-Basic-GetFeature-tc33.1 test.
>>>
>>> If desired, i can post these in a separate thread.
>>>
>>> Best regards
>>> baris
>>>
>>> On 4/26/2013 9:12 AM, BARIS KAZAR wrote:
>>>> Hi Sebastian,-
>>>> Thanks, when will TeamEngine 4.0 be operational?
>>>> i also find some issues with some of the GetFeature GET KVP
>>> tests, i am still trying to determine the problem.
>>>> I tested some of them outside the TeamEngine and they
>>> executed fine and they were working fine with Revision 3972
>>> (TeamEngine 3.x).
>>>> Best regards
>>>> baris
>>> _______________________________________________
>>> CITE-Forum mailing list
>>> CITE-Forum at lists.opengeospatial.org
>>> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
>>>
>



More information about the CITE-Forum mailing list