[CITE-Forum] WPS 1.0.0 r1 tests

Richard Martell rmartell at galdosinc.com
Wed Apr 24 11:41:02 EDT 2013


Benjamin,


This is a bug in the script in that it doesn't allow for multiple exceptions 
(1..*) appearing in the report--this is permitted as you pointed out. 
 
<http://schemas.opengis.net/ows/1.1.0/owsExceptionReport.xsd>


And one cannot assume that the exceptions are ordered in any manner. 
Please submit a bug report at <http://cite.opengeospatial.org/issues>*.


* I see there's no entry for WPS 1.0 in the "Category" field. Luis,
can you add it please?


--
Richard
 


________________________________

	From: cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial.org [mailto:cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial.org] On Behalf Of Benjamin Proß
	Sent: Tuesday, 23 April, 2013 08:08
	To: CITE-Forum at lists.opengeospatial.org
	Subject: [CITE-Forum] WPS 1.0.0 r1 tests
	
	
	List,
	
	While testing our WPS 1.0.0 implementation, we came across the following (possible) issue:
	
	The ExceptionReport responses of our WPS contain more than one Exception element and therefore also more than one exceptionCode attribute.
	We think, this is correct based on Table 57 in OGC 05-007r7 and section 8.2 in OGC 06-121r3.
	The test now seems to concatenate the exceptionCodes and then fails because this doesn't match the expected code, e.g. "MissingParameterValue". 
	Shouldn't it be tested, whether the concatenation contains the expected exceptionCode instead?
	Please find attached a test log of the OWS.GetCapabilities-Exceptions.1 test. This issue would affect several more tests, though.
	
	Cheers,
	
	Benjamin
	
	-- 
	Benjamin Proß
	52°North Initiative for Geospatial Open Source Software GmbH
	Martin-Luther-King-Weg 24
	E-Mail: b.pross at 52north.org
	Fon: +49-(0)-251-396371-42
	Fax: +49-(0)-251-396371-11
	http://www.52north.org
	General Managers: Dr. Albert Remke, Dr. Andreas Wytzisk
	Local Court Muenster HRB 10849
	



More information about the CITE-Forum mailing list