[CITE-Forum] ets-owc build fails

Jeronimo Wanhoff wanhoff at lat-lon.de
Mon Apr 8 04:11:20 EDT 2013


Thank you, Richard.

The build succeeds now, even if I remove the teamengine modules from my
local repository.

Regards,
  Jeronimo

Am 30.03.2013 23:58, schrieb Richard Martell:
> Jeronimo,
>  
> I added the teamengine-spi-4.0-beta2 module to the OGC repository.
> 
> --
> Richard
> 
>     ------------------------------------------------------------------------
>     *From:*
>     cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial.org
>     [mailto:cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial.org]
>     *On Behalf Of *Richard Martell
>     *Sent:* Thursday, 28 March, 2013 16:56
>     *To:* Jeronimo Wanhoff; cite-forum at lists.opengeospatial.org
>     *Subject:* Re: [CITE-Forum] ets-owc build fails
> 
>     Jeronimo,
>      
>      
>     They just haven't been added yet. We're still deliberating about a
>     final resting place
>     (e.g. a public Maven repository, one maintained by OGC/CITE, etc.).
>      
> 
>     --
>     Richard
> 
> 
>         ------------------------------------------------------------------------
>         *From:*
>         cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial.org
>         [mailto:cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial.org]
>         *On Behalf Of *Jeronimo Wanhoff
>         *Sent:* Thursday, 28 March, 2013 10:36
>         *To:* cite-forum at lists.opengeospatial.org
>         *Subject:* Re: [CITE-Forum] ets-owc build fails
> 
>         Hi,
> 
>         thanks for your help. The link to the svn repository solves my
>         problem.
> 
>         May I ask, why the beta1 packages made it into the repository,
>         but the beta2 packages are missing?
> 
>         Kind regards,
>           Jeronimo
> 
>         --
>         l a t / l o n  GmbH
>         Aennchenstrasse 19                 53177 Bonn, Germany
>         phone ++49 +228 18496-0            fax ++49 +228 18496-29
>         http://www.lat-lon.de
>         <http://www.lat-lon.de/>              http://www.deegree.org
>         <http://www.deegree.org/>
> 
>         * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
>         Follow deegree on Twitter: http://twitter.com/deegree_org
> 
>         Am 28.03.2013 um 18:06 schrieb Richard Martell:
> 
>>         Hi Jeronimo,
>>
>>
>>         The owc suite depends on a module in teamengine (teamengine-spi).
>>         So you'll also need to check out and build teamengine 4.0-beta2:
>>
>>         It can be checked out from the Subversion repository at
>>         SourceForge:
>>         <http://svn.code.sf.net/p/teamengine/code/tags/4.0-beta2/>
>>
>>
>>         Just run "mvn install" against the top-level POM to build and
>>         install
>>         everything into your local Maven repository, thereby making it
>>         available.
>>
>>
>>         --
>>         Richard
>>
>>
>>>         -----Original Message-----
>>>         From:
>>>         cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial <mailto:cite-forum-bounces+rmartell=galdosinc.com at lists.opengeospatial>
>>>         .org
>>>         [mailto:cite-forum-bounces+rmartell=galdosinc.com at lists.openge <mailto:galdosinc.com at lists.openge>
>>>         ospatial.org <http://ospatial.org>] On Behalf Of Luis E. Bermudez
>>>         Sent: Tuesday, 26 March, 2013 19:31
>>>         To: Jeronimo Wanhoff
>>>         Cc: cite-forum at lists.opengeospatial.org
>>>         <mailto:cite-forum at lists.opengeospatial.org>
>>>         Subject: Re: [CITE-Forum] ets-owc build fails
>>>
>>>         Hi Jeronimo
>>>
>>>         I see this jar is missing
>>>         https://svn.opengeospatial.org/ogc-projects/cite/maven/org/ope
>>>         ngis/cite/teamengine/teamengine-spi/4.0-beta2/teamengine-spi-4
>>>         .0-beta2.jar
>>>         We are checking !
>>>
>>>         ---
>>>         Luis
>>>         http://www.opengeospatial.org/ogc/organization/staff/lbermudez
>>>         The OGC: Making Location Count
>>>
>>>         On Mar 26, 2013, at 8:44 AM, Jeronimo Wanhoff wrote:
>>>
>>>
>>>         Hi all,
>>>
>>>         I just checked out the ets-owc-Build from [1]. I tried
>>>         to build the
>>>         project, but got a dependecy error:
>>>
>>>         ----
>>>
>>>         [INFO]
>>>
>>>         --------------------------------------------------------------
>>>         ----------
>>>         [INFO] Building OWS Context (OWC 1.0) Conformance Test
>>>         Suite 1.0-r3-SNAPSHOT
>>>         [INFO]
>>>
>>>         --------------------------------------------------------------
>>>         ----------
>>>         Downloading:
>>>
>>>         https://svn.opengeospatial.org/ogc-projects/cite/maven/org/ope
>>>         ngis/cite/teamengine/teamengine-spi/4.0-beta2/teamengine-spi-4
>>>         .0-beta2.pom
>>>         Downloading:
>>>
>>>         http://repo.maven.apache.org/maven2/org/opengis/cite/teamengin
>>>         e/teamengine-spi/4.0-beta2/teamengine-spi-4.0-beta2.pom
>>>         [WARNING] The POM for
>>>
>>>         org.opengis.cite.teamengine:teamengine-spi:jar:4.0-beta2 is
>>>         missing, no
>>>         dependency information available
>>>         Downloading:
>>>
>>>         https://svn.opengeospatial.org/ogc-projects/cite/maven/org/ope
>>>         ngis/cite/teamengine/teamengine-spi/4.0-beta2/teamengine-spi-4
>>>         .0-beta2.jar
>>>         Downloading:
>>>
>>>         http://repo.maven.apache.org/maven2/org/opengis/cite/teamengin
>>>         e/teamengine-spi/4.0-beta2/teamengine-spi-4.0-beta2.jar
>>>         [INFO]
>>>
>>>         --------------------------------------------------------------
>>>         ----------
>>>         [INFO] BUILD FAILURE
>>>         [INFO]
>>>
>>>         --------------------------------------------------------------
>>>         ----------
>>>         [INFO] Total time: 3.721s
>>>         [INFO] Finished at: Tue Mar 26 13:34:09 CET 2013
>>>         [INFO] Final Memory: 9M/200M
>>>         [INFO]
>>>
>>>         --------------------------------------------------------------
>>>         ----------
>>>         [ERROR] Failed to execute goal on project ets-owc:
>>>         Could not resolve
>>>         dependencies for project
>>>         org.opengis.cite:ets-owc:jar:1.0-r3-SNAPSHOT:
>>>         Could not find artifact
>>>         org.opengis.cite.teamengine:teamengine-spi:jar:4.0-beta2 in
>>>         opengeospatial-cite
>>>
>>>         (https://svn.opengeospatial.org/ogc-projects/cite/maven) ->
>>>         [Help 1]
>>>
>>>         ----
>>>
>>>         Maven complains that the dependency to
>>>         teamengine-spi-4.0-beta2.jar
>>>         cannot be found in the maven repository. That is
>>>         correct, the dependency
>>>         is missing in [2]. Only beta1 packages, e.g. [3], but
>>>         no beta2 packages
>>>         can be found there.
>>>
>>>         Could someone please upload the missing artefacts?
>>>
>>>         Kind regards,
>>>         Jeronimo
>>>
>>>         [1]
>>>
>>>         https://svn.opengeospatial.org/ogc-projects/cite/ets/testng/et
>>>         s-owc/trunk
>>>         [2] https://svn.opengeospatial.org/ogc-projects/cite/maven
>>>         [3]
>>>
>>>         https://svn.opengeospatial.org/ogc-projects/cite/maven/org/ope
>>>         ngis/cite/teamengine/teamengine-spi/4.0-beta1/teamengine-spi-4
>>>         .0-beta1.jar
>>>
>>>         -- 
>>>         Jeronimo Wanhoff
>>>
>>>         l a t / l o n  GmbH
>>>         Aennchenstrasse 19                 53177 Bonn, Germany
>>>         phone ++49 +228 18496-0            fax ++49 +228 18496-29
>>>         http://www.lat-lon.de              http://www.deegree.org
>>>
>>>         _______________________________________________
>>>         CITE-Forum mailing list
>>>         CITE-Forum at lists.opengeospatial.org
>>>         <mailto:CITE-Forum at lists.opengeospatial.org>
>>>         https://lists.opengeospatial.org/mailman/listinfo/cite-forum
>>>
>>>
>>>
>>>
> 


-- 
Jeronimo Wanhoff

l a t / l o n  GmbH
Aennchenstrasse 19                 53177 Bonn, Germany
phone ++49 +228 18496-0            fax ++49 +228 18496-29
http://www.lat-lon.de              http://www.deegree.org

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 261 bytes
Desc: OpenPGP digital signature
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20130408/45f90c64/attachment.pgp>


More information about the CITE-Forum mailing list