[CITE-Forum] WFS 1.0.0 GetFeature test case failure

Alok Sarawat alok.sarawat at pb.com
Fri Feb 24 08:50:38 EST 2012


Hi Andreas,

Thanks for the reply.

I validated it against schema and there is no validation error in the xml. I also used GML validator for verification also http://cite.opengeospatial.org/test_engine/gml/2.1.2/validator/

I also tried other implementations and they are also using their own element type instead of gml:pointProperty.

Other e.g. 
http://www2.dmsolutions.ca/cgi-bin/mswfs_gmap?request=GetFeature&service=WFS&version=1.0.0&typeName=park
http://frameworkwfs.usgs.gov/framework/wfs/wfs.cgi?datastore=GNIS&service=WFS&request=GetFeature&version=1.0.0&typename=iso19112:SI_LocationInstance&OUTPUTFORMAT=GML2&MAXFEATURES=2

I also tried Gaia 3.4.2 to consume my WFS and it is also not giving any error.

Regards,
Alok Sarawat

-----Original Message-----
From: cite-forum-bounces+alok.sarawat=pb.com at lists.opengeospatial.org [mailto:cite-forum-bounces+alok.sarawat=pb.com at lists.opengeospatial.org] On Behalf Of Andreas Schmitz
Sent: Friday, February 24, 2012 3:14 PM
To: cite-forum at lists.opengeospatial.org
Subject: Re: [CITE-Forum] WFS 1.0.0 GetFeature test case failure

Alok Sarawat wrote:

Hi,

> 
> I have attached DescribeFeatureType and GetFeature response with mail. 
> According to DescribeFeatureType response it is a valid xml. I am not 
> sure what is the problem with GetFeature response.
> 
> Please let me know where is the problem.

you need to use the official CITE application schema that comes with the test data, as these are used for validation. The geometry property for cdf:Other is a standard gml:pointProperty, so instead of your cdf:Obj a gml:pointProperty element is expected. Try validating the response against the official schemas to see what else might need fixing.

Best regards,
Andreas


More information about the CITE-Forum mailing list