[CITE-Forum] Regarding getmap:bbox-exponential test for WMS 1.3.0

Yingqi Tang anakintang at gmail.com
Thu Feb 2 09:37:35 EST 2012


Andreas,

Thanks a lot for looking into this, and I really appreciate it. I will try
different things to see if I can workaround it.

Yingqi

On Thu, Feb 2, 2012 at 12:42 AM, Andreas Schmitz <schmitz at lat-lon.de> wrote:

> Yingqi Tang wrote:
>
> Hi,
>
> > One more question, when you see it working, what version of JRE/JDK
> you're
> > using and also what web server you use to deploy the team engine? I can
> > probably try with those combination to see if I can reproduce the
> problem.
> > I still believe there is a double url encoding issue somewhere in test
> > engine, what happens to other services may be that some web server may
> > tolerate the double url encoded string.
>
> I'm using the deegree implementation on Tomcat 6.0.29 with Java
> 1.6.0_26:
>
>
> http://artefacts.deegree.org/libs-releases-local/org/deegree/deegree-compliance-tests/3.2-pre3/deegree-compliance-tests-3.2-pre3.war
>
> > Can you try debugging into the first a few lines of "parse" method of
> > HTTPParser class of test engine and see what url is sent?
>
> Attached is a screenshot. As you can see, eg. the CRS and LAYERS
> parameters are properly URL encoded, once.
>
> Best regards,
> Andreas
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
>
> iEYEARECAAYFAk8qTFUACgkQ737OVr+Ru7rVjQCguyaE51pVSyqQnGkOg0eJ/szA
> PkUAoLmXH7VILxgv1k3N3KJBolKppL+4
> =W8Pd
> -----END PGP SIGNATURE-----
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20120202/9be4ae8b/attachment.htm>


More information about the CITE-Forum mailing list