[CITE-Forum] SOS 1.0.0 r2 Test Suite with TEAM Engine Beta release

Carsten Hollmann c.hollmann at 52north.org
Tue Apr 10 02:51:50 EDT 2012


Dear Rocky,

Ok, it is interesting that you got different results. When I had
performed the tests several times, I got always the described error
messages.

I hope to have time for testing our SOS with the TEAM-Engine this weak
and I let you know about the results.

Regards,
Carsten


Am 06.04.2012 11:44, schrieb 宗岩 Rocky:
> Dear Carsten:
> 
>          I use this TEAM-Engine url: http://cite.opengeospatial.org/te2/ to test your service "http://188.111.111.60/52nSOSv350_100/sos", And I got different results.
>          Maybe you can test your service by this URL.
>          Or you can download the newest scripts and TEAM-Engine server to test on your own PC.
>          The newest scripts: https://svn.opengeospatial.org/ogc-projects/cite/scripts/
>          The newest TEAM-Engine: https://teamengine.svn.sourceforge.net/svnroot/teamengine/tags/beta-3.1
> 
> 
> 
> ----------------------------------------------------------------------------------------------------------------------------------
> Tsung-Yen Lee (Rocky)
> assistant software engineer
> GIS Research Center, Feng-Chia University Taiwan
> 
> -----Original Message-----
> From: Carsten Hollmann [mailto:c.hollmann at 52north.org]
> Sent: Thursday, April 05, 2012 2:15 PM
> To: 宗岩 Rocky
> Cc: Luis Bermudez; cite-forum at lists.opengeospatial.org; 嵐焜 Peter; 文元 Cool
> Subject: Re: [CITE-Forum] SOS 1.0.0 r2 Test Suite with TEAM Engine Beta release
> 
> Dear Rocky,
> 
> of course, you can find the log file in the attachment.
> 
> Regards,
> Carsten
> 
> Am 05.04.2012 02:08, schrieb 宗岩 Rocky:
>> Dear Carsten,
>>
>>           We still check the error about the test " sos:core-main" that all sub test are passed but the test sos:core-main failed.
>>
>>           But I don't get error message when testing " sos:general-SOS.General-InvalidRequest.1" and " sos:core-main".
>>           Maybe you can send me the log file or give me an URL to test your service.
>>
>>           Thank you.
>>
>> ----------------------------------------------------------------------------------------------------------------------------------
>> Tsung-Yen Lee (Rocky)
>> assistant software engineer
>> GIS Research Center, Feng-Chia University Taiwan
>>
>>
>>
>> -----Original Message-----
>> From: cite-forum-bounces+rocky=gis.tw at lists.opengeospatial.org [mailto:cite-forum-bounces+rocky=gis.tw at lists.opengeospatial.org] On Behalf Of Luis Bermudez
>> Sent: Friday, March 23, 2012 9:00 PM
>> To: Carsten Hollmann
>> Cc: cite-forum at lists.opengeospatial.org
>> Subject: Re: [CITE-Forum] SOS 1.0.0 r2 Test Suite with TEAM Engine Beta release
>>
>> Dear Carsten,
>>
>> Thank you for reporting these issues. We are investigating and will respond to these issues very soon.
>>
>> Luis
>> -------------
>> Luis Bermudez
>> lbermudez at opengeospatial.org
>> +1 (301) 760-7323
>>
>> The OGC: Making Location Count...
>> http://www.opengeospatial.org/contact
>>
>>
>>
>>
>> On Mar 22, 2012, at 4:10 AM, Carsten Hollmann wrote:
>>
>>> Hi,
>>>
>>> I have tested the 52°North SOS with the TEAM Engine Beta release. The test suite revision for the SOS 1.0.0 was r2.
>>>
>>> First, I want to mention some general issues and questions of the SOS 1.0.0 r2 test I have found:
>>>
>>> - Which specifications are used? The information page for the SOS 1.0.0 r2 test defines that the OGC specifications OWS 1.0 is used but in the namespace section 'http://www.opengis.net/ows/1.1' is mentioned. And which SOS specification document is used? The OGC 06-009r5 document or the OGC 06-009r6 document?
>>>
>>> - Why contains the KVP GetCapabilities request in some cases a 'version' parameter which is not defined in the specification for this operation?
>>>
>>> - If you push the button 'Execute this session again' in the test session results the website to define the tests opens. I think, it would be nice if the SOS location is set to the URL which was tested before and not to the default URL.
>>>
>>>
>>> The test with the 52°North SOS fails overall and not all tests are executed but some executed sub test passed. Here are the descriptions of the failed tests:
>>>
>>> - owsTests:ows-OWS.GetCapabilities.1
>>> Fails but all sub tests passed. The response is schema valid (tested with XMLSpy) and the root element is correct. So I do not have any idea why it fails because there are no details in the result.
>>>
>>> - sos:general-SOS.General-InvalidRequest.1
>>> Here is the Error message from the result:
>>> Error in call to extension function {public org.w3c.dom.NodeList com.occamlab.te.TECore.request(org.w3c.dom.Document,java.lang.String) throws java.lang.Throwable}: Exception in extension function java.lang.Exception: Error invoking parser {http://www.occamlab.com/te/parsers}XMLValidatingParser
>>> org.xml.sax.SAXParseException: schema_reference.4: Failed to read schema document 'file:/xsd/ogc/ows/1.1.0/owsExceptionReport.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not<xsd:schema>.
>>>
>>> - sos:core-main
>>> Here is the Error message from the result:
>>> Error in call to extension function {public org.w3c.dom.NodeList com.occamlab.te.TECore.request(org.w3c.dom.Document,java.lang.String) throws java.lang.Throwable}: Exception in extension function java.lang.Exception: Error invoking parser {http://www.occamlab.com/te/parsers}XMLValidatingParser
>>> org.xml.sax.SAXParseException: schema_reference.4: Failed to read schema document 'file:/xsd/ogc/sos/1.0.0/sosGetCapabilities.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not<xsd:schema>.
>>>
>>> Regards,
>>> Carsten
>>>
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> CITE-Forum mailing list
>>> CITE-Forum at lists.opengeospatial.org
>>> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
>>
>> _______________________________________________
>> CITE-Forum mailing list
>> CITE-Forum at lists.opengeospatial.org
>> https://lists.opengeospatial.org/mailman/listinfo/cite-forum
>>
>>
>> -----Disclaimer-----
>> 本郵件含有逢甲大學地理資訊系統研究中心機密資訊、或受法律保護之資料,唯有原發信人指定之收信人得閱讀或使用本郵件之內容。如您並非被指定之收信人,請立即將本郵件及所有附件予以刪除;請勿揭露、儲存或使用本郵件之任何資訊,並請您立即告知原發信人rocky at gis.tw本郵件的傳遞錯誤。謝謝您的合作。
>> This e-mail transmission and any attachments contain information from Geographic Information Systems Research Center of Feng Chia University. The information is confidential and/or privileged and intended to be solely for the use of the individuals or entity named in this e-mail transmission. If you are not the intended recipient, be aware that any disclosure, saving or use of the contents of this e-mail transmission and attachments is strictly prohibited. If you have received this email transmission in error, please notify us immediately, and delete the e-mail and attachments. We greatly appreciate your cooperation.
>> GIS RESEARCH CENTER, FCU http://www.gis.tw .Tel: 886-4-24516669
> 
> 
> -----Disclaimer-----
> 本郵件含有逢甲大學地理資訊系統研究中心機密資訊、或受法律保護之資料,唯有原發信人指定之收信人得閱讀或使用本郵件之內容。如您並非被指定之收信人,請立即將本郵件及所有附件予以刪除;請勿揭露、儲存或使用本郵件之任何資訊,並請您立即告知原發信人rocky at gis.tw本郵件的傳遞錯誤。謝謝您的合作。
> This e-mail transmission and any attachments contain information from Geographic Information Systems Research Center of Feng Chia University. The information is confidential and/or privileged and intended to be solely for the use of the individuals or entity named in this e-mail transmission. If you are not the intended recipient, be aware that any disclosure, saving or use of the contents of this e-mail transmission and attachments is strictly prohibited. If you have received this email transmission in error, please notify us immediately, and delete the e-mail and attachments. We greatly appreciate your cooperation.
> GIS RESEARCH CENTER, FCU http://www.gis.tw .Tel: 886-4-24516669


More information about the CITE-Forum mailing list