[CITE-Forum] OGC TEAM Engine WFS 1.0.0 testing

Fergus Brazier Fergus.Brazier at cadcorp.com
Mon Jun 13 11:59:36 EDT 2011


Hi,

My last post clearly did not have enough information.

Whilst testing using the OGC TEAM Engine for WFS1.0.0 we have 2 failures:

Test wfs:test1.0.0-basic-describefeaturetype-get-4 (s0001/d40e704_1)

Assertion: When a wfs:DescribeFeatureType request is made without a TypeName, the result document must be an GML XML schema document that describes all feature types served by the WFS.

Request d40e4868_1:
   Method: get
   URL: http://ogc.cadcorpsis.com/WFS/wfs.exe?&service=WFS&version=1.0.0&request=DescribeFeatureType
   Response from parser ::
      <xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified">
   <xsd:import namespace="http://www.opengis.net/cite/data"
               schemaLocation="http://ogc.cadcorpsis.com/WFS/wfs.exe?request=DescribeFeatureType&version=1.0.0&service=WFS&typename=cdf:Nulls,cdf:Seven,cdf:Fifteen,cdf:Other,cdf:Autos,cdf:BasicPolygons,cdf:Bridges,cdf:BuildingCenters,cdf:Buildings,cdf:DividedRoutes,cdf:Forests,cdf:Lakes,cdf:LakesWithElevation,cdf:MapNeatline,cdf:NamedPlaces,cdf:Ponds,cdf:RoadSegments,cdf:Streams,cdf:cite_NonQueryable,cdf:Autos.xml,cdf:BasicPolygons.xml,cdf:Bridges.xml,cdf:Buildings.xml"/>
   <xsd:import namespace="http://www.opengis.net/cite/geometry"
               schemaLocation="http://ogc.cadcorpsis.com/WFS/wfs.exe?request=DescribeFeatureType&version=1.0.0&service=WFS&typename=cgf:Points,cgf:Lines,cgf:Polygons,cgf:MPoints,cgf:MLines,cgf:MPolygons"/>
   <!--Response received in [515] milliseconds--></xsd:schema>

Result: Failed


Test wfs:test1.0.0-basic-describefeaturetype-post-4 (s0001/d40e778_1)



Assertion: When a wfs:DescribeFeatureType request is made without a TypeName, the result document must be an GML XML schema document that describes all feature types served by the WFS.



Request d40e5346_1:

   Method: post

   URL: http://ogc.cadcorpsis.com/WFS/wfs.exe

   Body:

<wfs:DescribeFeatureType xmlns="http://www.occamlab.com/ctl"

                         xmlns:ccf="http://www.opengis.net/cite/complex"

                         xmlns:cdf="http://www.opengis.net/cite/data"

                         xmlns:cgf="http://www.opengis.net/cite/geometry"

                         xmlns:citef="http://www.opengis.net/cite/functions"

                         xmlns:ctl="http://www.occamlab.com/ctl"

                         xmlns:gml="http://www.opengis.net/gml"

                         xmlns:ogc="http://www.opengis.net/ogc"

                         xmlns:parsers="http://www.occamlab.com/te/parsers"

                         xmlns:saxon="http://saxon.sf.net/"

                         xmlns:te="http://www.occamlab.com/te"

                         xmlns:tec="java:com.occamlab.te.TECore"

                         xmlns:wfs="http://www.opengis.net/wfs"

                         xmlns:xlink="http://www.w3.org/1999/xlink"

                         xmlns:xs="http://www.w3.org/2001/XMLSchema"

                         outputFormat="XMLSCHEMA"

                         service="WFS"

                         version="1.0.0"/>

   Response from parser ::

      <xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified">

   <xsd:import namespace="http://www.opengis.net/cite/data"

               schemaLocation="http://ogc.cadcorpsis.com/WFS/wfs.exe?request=DescribeFeatureType&version=1.0.0&service=WFS&typename=cdf:Nulls,cdf:Seven,cdf:Fifteen,cdf:Other,cdf:Autos,cdf:BasicPolygons,cdf:Bridges,cdf:BuildingCenters,cdf:Buildings,cdf:DividedRoutes,cdf:Forests,cdf:Lakes,cdf:LakesWithElevation,cdf:MapNeatline,cdf:NamedPlaces,cdf:Ponds,cdf:RoadSegments,cdf:Streams,cdf:cite_NonQueryable,cdf:Autos.xml,cdf:BasicPolygons.xml,cdf:Bridges.xml,cdf:Buildings.xml"/>

   <xsd:import namespace="http://www.opengis.net/cite/geometry"

               schemaLocation="http://ogc.cadcorpsis.com/WFS/wfs.exe?request=DescribeFeatureType&version=1.0.0&service=WFS&typename=cgf:Points,cgf:Lines,cgf:Polygons,cgf:MPoints,cgf:MLines,cgf:MPolygons"/>

   <!--Response received in [531] milliseconds--></xsd:schema>



Result: Failed
The responses do not include the Feature Type definitions inline, but do so via xsd:import.
Is this type of response supported?
Kind regards,
Fergus
Fergus M Brazier
GIS Technical Specialist
Cadcorp
Sterling Court, Norton Road, Stevenage, Herts, SG1 2JY, UK
Tel : +44 (0)1438 731437
Fax: +44 (0)1438 747997
Mob: +44 (0)7725 866708
Fergus.Brazier at cadcorp.com<mailto:Fergus.Brazier at cadcorp.com>
www.cadcorp.com<file:///\\www.cadcorp.com\>

****************************************************************************
This email is confidential and may be privileged and should not be used, read
or copied by anyone who is not the  original intended recipient. If you have
received this email in error  please inform the sender and delete it from
your mailbox or any other storage mechanism. Unless specifically stated,
nothing in this email constitutes an offer by Cadcorp and Cadcorp does not
warrant that any information contained in this email is accurate.
Cadcorp cannot accept liability for any statements made which are clearly the
sender's own and not expressly made on behalf of Cadcorp or one of its agents.
Please rely on your own virus check. No responsibility is taken by Cadcorp
for any damage arising out of any bug or virus infection.
****************************************************************************
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20110613/6cd8e581/attachment-0001.htm>


More information about the CITE-Forum mailing list