[CITE-Forum] wfs-1.1.0-Basic-GetFeature-tc204.1 test

Andreas Schmitz schmitz at lat-lon.de
Thu Nov 11 02:19:48 EST 2010


Baris Kazar wrote:

Hi,

> The request for wfs-1.1.0-Basic-GetFeature-tc204.1 is as follows:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <!-- test case id: wfs-1.1.0-Basic-GetFeature-tc204.1 -->
> <wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs" version="1.1.0"  
> service="WFS">
>  <wfs:Query xmlns:sf="http://cite.opengeospatial.org/gmlsf"  
> typeName="sf:EntiteGenerique">
>    <ogc:Filter xmlns:ogc="http://www.opengis.net/ogc"  
> xmlns:gml="http://www.opengis.net/gml">
>      <ogc:Overlaps>
>        <ogc:PropertyName>sf:attribut.Geometrie</ogc:PropertyName>
>        <gml:Envelope srsName="urn:x-ogc:def:crs:EPSG:6.11.2:4326">
>          <gml:lowerCorner>56.05 -2.00</gml:lowerCorner>
>          <gml:upperCorner>62.11 2.02</gml:upperCorner>
>        </gml:Envelope>
>      </ogc:Overlaps>
>    </ogc:Filter>
>  </wfs:Query>
> </wfs:GetFeature>
>
> And the response is as follows:
>
> <?xml version="1.0" encoding="UTF-8"?><wfs:FeatureCollection  
> xmlns="http://www.w3.org/2001/XMLSchema"  
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"  
> xsi:schemaLocation="http://cite.opengeospatial.org/gmlsf  
> HTTP://localhost:7101/SpatialWFS-WfsXml-context-root/xmlwfsservlet?featureTypeId=3 
> " xmlns:wfs="http://www.opengis.net/wfs">
> <gml:boundedBy xmlns:gml="http://www.opengis.net/gml">
> <gml:Envelope srsName="EPSG:4326"><gml:lowerCorner>60.5  
> 0.0</gml:lowerCorner><gml:upperCorner>64.0  
> 6.25</gml:upperCorner></gml:Envelope>
> </gml:boundedBy>
> <gml:featureMember xmlns:gml="http://www.opengis.net/gml">
> <sf:EntiteGenerique gml:id="EntiteGenerique.f004"  
> xmlns:sf="http://cite.opengeospatial.org/gmlsf">
> <gml:description>description-f004</gml:description>
> <gml:name>name-f004</gml:name>
> <sf:attribut.Geometrie>
> <gml:Polygon srsName="SDO:4326">
> <gml:exterior><gml:LinearRing><gml:posList>60.5 0.0 64.0 0.0 64.0 6.25  
> 60.5 6.25 60.5 0.0  </gml:posList>
> </gml:LinearRing></gml:exterior>
> <gml:interior><gml:LinearRing><gml:posList>61.5 2.0 62.5 2.0 62.0 4.0  
> 61.5 2.0 </gml:posList>
> </gml:LinearRing></gml:interior></gml:Polygon>
> </sf:attribut.Geometrie>
> <sf:boolProperty>1</sf:boolProperty>
> <sf:str4Property>abc3</sf:str4Property>
> </sf:EntiteGenerique>
> </gml:featureMember>
> </wfs:FeatureCollection>
>
> Why should we have gml:_Feature in the response as the error tells:
> cvc-complex-type.2.4.a: Invalid content was found starting with element  
> 'sf:EntiteGenerique'. One of '{"http://www.opengis.net/gml":_Feature}'  
> is expected.
>
> (Please assume accents are in appropriate places).

although you think the accents are in the appropriate places, I assume
they're not. The schema validation expects an element in the
substitution group of gml:_Feature, and for some reason he cannot
validate that your element is in that substitution group. Maybe there's
a problem with the response encoding? You can try to validate your
response document with an XML editor such as XMLSpy, it will tell you
the same thing.

Best regards, Andreas
-- 
l a t / l o n  GmbH
Aennchenstrasse 19               53177 Bonn, Germany
phone ++49 +228 18496-0          fax ++49 +228 18496-29
http://www.lat-lon.de            http://www.deegree.org

* * * * * * * * * * * * * * * * * * * * * * * * * * * *
                    deegree day 2010
             http://deegreeday.deegree.org
* * * * * * * * * * * * * * * * * * * * * * * * * * * *

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://lists.opengeospatial.org/pipermail/cite-forum/attachments/20101111/8486afc3/attachment.pgp>


More information about the CITE-Forum mailing list