[CITE-Forum] WFS 1.1.0 Test Data

Raj Singh rsingh at opengeospatial.org
Wed Aug 19 16:13:36 EDT 2009


I believe this issue has been recently uncovered by another tester,  
completely independently. There certainly seems to be a problem with  
the test data here.

-----
Raj Singh
Compliance Test Coordinator
Open Geospatial Consortium
rsingh at opengeospatial.org
+1 (617) 642-9372

** making location count **




On Aug 19, at 5:38 AM, Neil Tippett wrote:

> Hi folks,
>
> I have a query about the GML SF-0 schema provided with the CITE WFS  
> 1.1 test data. Specifically, if my understanding of the SF-0 profile  
> is correct, it doesn’t appear to comply with the feature property  
> rules.
>
> The issues I’ve noted include:
>
> ·         The definition of the ‘FeatureCodeType’ simple type uses  
> the ‘pattern’ facet which isn’t listed as a permitted facet for  
> string types.
> ·         The definition of the ‘EntitéGénériqueType’ complex type  
> uses the built-in schema type ‘NCName’,  which again is not listed  
> as a permitted property type by the profile.
> ·         The definition of the ‘PrimitiveGeoFeatureType’ complex  
> type uses the built-in schema type ‘float’,  which again is not  
> listed as a permitted property type by the profile.
> ·         Depending upon your interpretation of the profile, the use  
> of non-inline type definitions (E.G. ‘String4PropertyType’ and  
> ‘IntRangePropertyType’) is not stated as being permitted. It is also  
> not strictly forbidden either. Does the use of them in this test  
> data imply that they are permitted?
>
> Is the test data wrong or is it my understanding of the profile?
>
> Many thanks,
>
> Neil
> _______________________________________________
> CITE-Forum mailing list
> CITE-Forum at lists.opengeospatial.org
> https://lists.opengeospatial.org/mailman/listinfo/cite-forum




More information about the CITE-Forum mailing list