[CITE-Forum] WCS 1.0.0 timePosition parameter is not retrieve correctly

Normand Savard nsavard at mapgears.com
Tue Aug 11 15:37:36 EDT 2009


The wcs1-0-0:getcoverage_operations-getcoverage_request-time-get-kvp-2 test failed on the
beta testing Web site (http://cite.opengeospatial.org/te2/) because the timePosition parameter is
not retrieved correctly from the capabilities document.  The test try to get the the value
from the timePositions parameter that does not exist.  The time parameter is set to VAR_WCS_COVERAGE_1_TIME 
variable that is an empty string.

http://dev1.lan.mapgears.com/manwe/cgi-bin/mswcs100_ogc_cite?&VeRsIoN=1.0.0&FoRmAt=GeoTIFF&TiMe=&CrS=EPSG:4326&CoVeRaGe=ndvi&ReQuEsT=GetCoverage&HeIgHt=100&SeRvIcE=WCS&WiDtH=200


Could someone verify this?

Norm




The test:
<xsl:variable xmlns:xsl="http://www.w3.org/1999/XSL/Transform" name="VAR_WCS_COVERAGE_1_TIME">
  <xsl:for-each select="$request1">
    <xsl:value-of select="string(/*[local-name()='CoverageDescription'][namespace-uri()='http://www.opengis.org/wcs'][1]//*[local-name()='domainSet'][1]//*[local-name()='timePositions'][1])&#x9;&#x9;&#x9;&#x9;&#x9;&#x9;&#x9;"/>
  </xsl:for-each>
</xsl:variable>
<ctl:message>VAR_WCS_COVERAGE_1_TIME: <xsl:value-of xmlns:xsl="http://www.w3.org/1999/XSL/Transform"


The capabilites schema:
<xs:complexType name="LonLatEnvelopeType">
	<xs:annotation>
		<xs:documentation>Defines spatial extent by extending LonLatEnvelope with an optional time position pair. </xs:documentation>
	</xs:annotation>
	<xs:complexContent>
		<xs:extension base="LonLatEnvelopeBaseType">
			<xs:sequence minOccurs="0">
				<xs:element ref="gml:timePosition" minOccurs="2" maxOccurs="2"/>
			</xs:sequence>
		</xs:extension>
	</xs:complexContent>
</xs:complexType>





More information about the CITE-Forum mailing list