[CITE-Forum] [Fwd: WCS 1.0.0 legacy tests engine]

Kralidis,Tom [Burlington] Tom.Kralidis at ec.gc.ca
Mon Feb 11 11:05:04 EST 2008


Hi,

As per below.  We cannot further test interoperability or CITE WCS 1.0.0
compliance testing until
http://schemas.opengis.net/wcs/1.0.0/wcsCapabilities.xsd  is fixed to be
valid.

Please advise.

..Tom


> -----Original Message-----
> From: Kralidis,Tom [Burlington] 
> Sent: 30 January, 2008 11:32 AM
> To: cite-forum at opengeospatial.org
> Subject: RE: [Fwd: [CITE-Forum] WCS 1.0.0 legacy tests engine]
> 
> > 
> > -------- Original Message --------
> > Subject: 	[CITE-Forum] WCS 1.0.0 legacy tests engine
> > Date: 	Thu, 17 Jan 2008 15:59:22 -0500
> > From: 	Normand Savard <nsavard at mapgears.com>
> > To: 	cite-forum at opengeospatial.org
> > 
> > 
> > 
> > Hi,
> > 
> > I ran the Legacy test suite on our WCS 1.0.0 server.  I have one of 
> > the
> > tests that fails because of an XML validation error.   The test is  
> > wcs1-0-0/basic_service_elements/general_http_request_rules/4
> > <http://cite.opengeospatial.org/tsOGC/interface/ViewTestSource
> > ?testid=wcs1-0-0/basic_service_elements/general_http_request_r
> > ules/4&ts=0033&sesstype=OGC>
> > and the error is:
> > 
> > Mon Jan 14 15:57:55 EST 2008 : Line = 1 Column = 2021 Message =
> > {cvc-complex-type.2.4.b: The content of element 
> > 'VendorSpecificCapabilities' is not complete. It must match 
> > '((WC[##any]))'.}
> > 
> 
> VendorSpecificCapabilities is optional in 
> http://schemas.opengis.net/wcs/1.0.0/wcsCapabilities.xsd, so 
> I'm not sure why this error is occuring (I don't think 
> MapServer outputs this element).
> 
> > So I wanted to get more information on this error by validating the 
> > WCS 1.0.0 capababilities against its associated wcsCapabilities.xsd 
> > with XML Spy and I got the following error:
> > 
> > "Error in reference schema or DTD.  Type 
> 'AbstractDescriptionBaseType'
> > is not a valid restriction of type 'gml:AbstractGMLType'."
> > Do someone else got this error before?   Can someone give me 
> > some pointers?
> > 
> 
> I get the same error when trying to validate 
> http://schemas.opengis.net/wcs/1.0.0/wcsCapabilities.xsd with 
> XMLSpy 2008.  I wonder this has affected other WCS CITE tests?
> 
> ..Tom
> 



More information about the CITE-Forum mailing list