[CITE-Forum] Conflicts between wcs 1.0 and 1.1

Justin Deoliveira jdeolive at opengeo.org
Tue Aug 12 11:11:49 EDT 2008


Thanks Normand, good to know that others are seeing the same issue. 
Hopefully with two voices we can get a resolution on this one.

-Justin

Normand Savard wrote:
> Justin Deoliveira wrote:
>> Hi All,
>>
>> I think this issue came up during ows 5 and the wcs 1.1 testbed, but I 
>> thought I would bring it up again.
>>
>> Basically its not possible to pass all of the wcs 1.0 test cases while 
>> wcs 1.1 is active. The reason being that many of the tests omit the 
>> version parameter from requests, and then test for a particular 
>> exception. I can provide a list of all the tests that fail if need be.
>>
>> I am wondering if there is anything that can be done about this? Perhaps 
>> modifying the wcs 1.0 test suite? Currently the only workaround to pass 
>> the wcs 1.0 tests in GeoServer is to manually disable wcs 1.1 support... 
>> which is not ideal.
>>
>>   
> Justin,
> 
> I raised a similar issue to this list February 18th 2008 but I haven't 
> get a response yet from the list.  I pasted below the email I sent then.
> 
> Norm
> 
> Normand Savard wrote:
>> Hi,
>>
>> I have a question about WCS 1.0.0 GetCapabilities request.  The 
>> concerned CITE test is: 
>>
>> wcs1-0-0:basic_service_elements-version_numbering_and_negotiation-1 and the request is:
>>
>> http://dev1.lan.mapgears.com/manwe/cgi-bin/mswcs100_ogc_cite?&VeRsIoN=&SeRvIcE=WCS&ReQuEsT=GetCapabilities
>>
>> This test failed and some others because the "Capabilities" element is not found.  The 
>> reason for this is:  When the version number is not specified than the highest version
>> of the capabilities response is sent.  Since we do support 1.1.0 then the capabilities
>> response for this version is returned.  When the validation occurs against the 1.0.0 
>> capabilities schema, this test failed.
>>
>> I tried to set the version 1.1.0 in the GetCapabilites request of the tests suite but 
>> it failed with the following message:  Cannot find the declaration of element 
>> 'Capabilities'.
>>
>>
>> The capabilities response for 1.1.0 version is:
>>
>> <?xml version="1.0" encoding="ISO-8859-1"?>
>> <Capabilities xmlns="http://www.opengis.net/wcs/1.1" xmlns:ows="http://www.opengis.net/ows" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ogc="http://www.opengis.net/ogc" version="1.1.1" updateSequence="1">
>>  <ows:ServiceIdentification>
>>    <ows:Title/>
>> <!--WARNING: Optional metadata "ows_title" missing for ows:Title-->
>>    <ows:Abstract/>
>> ...
>>
>> and the one for 1.0.0 version is:
>>
>> <?xml version='1.0' encoding="ISO-8859-1" standalone="no" ?>
>> <WCS_Capabilities
>>   version="1.0.0" 
>>   updateSequence="1" 
>>   xmlns="http://www.opengis.net/wcs" 
>>   xmlns:xlink="http://www.w3.org/1999/xlink" 
>>   xmlns:gml="http://www.opengis.net/gml" 
>>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>   xsi:schemaLocation="http://www.opengis.net/wcs http://schemas.opengis.net//wcs/1.0.0/wcsCapabilities.xsd">
>>
>>   ...
>>
>>
>> How do we handle this case?  Does someone have an idea?
>>
>> Norm
>>
>>
>>
>> _______________________________________________
>> CITE-Forum mailing list
>> CITE-Forum at opengeospatial.org
>> https://mail.opengeospatial.org/mailman/listinfo/cite-forum
>>
>>   
> 
> 
> _______________________________________________
> CITE-Forum mailing list
> CITE-Forum at lists.opengeospatial.org
> https://lists.opengeospatial.org/mailman/listinfo/cite-forum


-- 
Justin Deoliveira
Software Engineer, OpenGeo
http://opengeo.org


More information about the CITE-Forum mailing list