[CITE-Forum] WFS 1.0.0 test failures do not provide descriptive error messages

David Hunt davidchunt at btinternet.com
Sat Dec 22 12:20:57 EST 2007


Hi Normand,

The problem is that (and someone correct me here if i am wrong) the
validation engine is not actually using the "schemaLocation" of your
returned document to validate. Its using a schema stored internally.

In other words it is not using the reflective describeFeatureType call
included in your output. And since in the copy of the schema it is using
the geometry property is named "pointProperty" and not "msGeometry" you
get an error.

Hope that helps.

-Justin

I think the key here is that the validation engine is not actually using
> I have a similar problem with wfs:test1.0.0-basic-getfeature-get-1 test.
I did the
> same validation (GML validator and XML Spy) and also visually validated a
part of the XML,
> everything looks fine.The TEAM engine reports the following error:
>
> 
>   Response from parser wfs:GMLValidatingParser:
>      
>    Messages from parser wfs:GMLValidatingParser:
>         error at line 22, column 25:
>   cvc-complex-type.2.4.a: Invalid content starting with element
'cdf:msGeometry'. The content must match
'((("http://www.opengis.net/gml":description){0-1},("http://www.opengis.net/
gml":name){0-1},("http://www.opengis.net/gml":boundedBy){0-1}),(("http://www
.opengis.net/gml":pointProperty){0-1},("http://www.opengis.net/cite/data":st
ring1),("http://www.opengis.net/cite/data":string2){0-1},("http://www.opengi
s.net/cite/data":integers){0-1},("http://www.opengis.net/cite/data":dates){0
-1}))'.
> 1 error detected.
>
>
> The request sent is:
>
> http://dev1.lan.mapgears.com/manwe/cgi-bin/mswfs100_ogc_cite?
<http://dev1.lan.mapgears.com/manwe/cgi-bin/mswfs100_ogc_cite?&service=WFS&v
ersion=1.0.0&request=GetFeature&outputformat=GML2&typename=cdf:Other>
&service=WFS&version=1.0.0&request=GetFeature&outputformat=GML2&typename=cdf
:Other
>
> Does someone has any suggestion on what may be the issue?
>
> Norm
>
> _______________________________________________
> CITE-Forum mailing list
> CITE-Forum at opengeospatial.org
> https://mail.opengeospatial.org/mailman/listinfo/cite-forum
>
> !DSPAM:4007,4766e56a83007082231907!
>


--
Justin Deoliveira
The Open Planning Project
http://topp.openplans.org
_______________________________________________
CITE-Forum mailing list
CITE-Forum at opengeospatial.org
https://mail.opengeospatial.org/mailman/listinfo/cite-forum


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.opengeospatial.org/pipermail/cite-forum/attachments/20071222/41a48617/attachment.htm 


More information about the CITE-Forum mailing list