[CITE-Forum] Change getcapabilities url on TEAM engine tests session

Normand Savard nsavard at mapgears.com
Mon Dec 10 15:30:01 EST 2007


Normand Savard wrote:

> Hi,
>
> We made some changes in our WMS and WFS server URL.  Our base URL 
> starts now with http://dev1.lan.mapgears.com/ instead of 
> http://www2.dmsolutions.ca/.  When I paste the getcapabilities URL in 
> the text field and I execute the tests, the original base URL is used 
> instead of the new one I specified for the WFS tests and is truncated 
> for the WMS tests.
>
> WFS URL pasted in the text field:
> http://dev1.lan.mapgears.com/manwe/cgi-bin/mswfs100_ogc_cite?service=wfs&version=1.0.0&request=getcapabilities 
> or
>
> Log for the WFS tests:
> Request w6ac29b9b1b1_1:
>
>   Method: get
>   URL: 
> http://www2.dmsolutions.ca/manwe/cgi-bin/mswfs_ogc_cite?&service=WFS&version=1.0.0&request=DescribeFeatureType 
>
>
> WMS URL pasted in the text field:
> http://dev1.lan.mapgears.com/manwe/cgi-bin/mswms111_ogc_cite?&service=WmS&version=1.0.0&request=getcapabilities 
>
>
> Log for the WMS tests:
> Parameter VAR_WMS_VERSION:
>   Label: 1.1.1
>   Value: 1.1.1
> Parameter VAR_WMS_GET_CAPABILITIES_HTTP_GET_URL:
>   Label: VAR_WMS_GET_CAPABILITIES_HTTP_GET_URL
>   Value:
> Request w6ac29c11b1b1_1:
>   Method: get
>   URL: SeRvIcE=WMS&BoGuS=ignored&ReQuEsT=GetCapabilities&VeRsIoN=1.1.1
> Error in call to extension function {public static 
> java.net.URLConnection 
> com.occamlab.te.TECore.build_request(org.w3c.dom.Node) throws 
> java.lang.Exception}: Exception in extension function 
> java.net.MalformedURLException: no protocol: 
> ?SeRvIcE=WMS&BoGuS=ignored&ReQuEsT=GetCapabilities&VeRsIoN=1.1.1; 
> SystemID: 
> file:/local/srv/tomcat/webapps/teamengine/WEB-INF/scripts/wms-1.1.1/ctl/wms.txsl; 
> Line#: 8979; Column#: -1
>
>
> Did someone notice this issue?
>
> Norm
>
All,

This is a configuration error.  Sorry for the noise.  Please ignore this 
email.

Norm


More information about the CITE-Forum mailing list